Can't log in to the game, code 10017


#1

I can’t log in to the Diablo III since yesterday

I tried Asian, American and Europian servers, it just show me a dialog says "unable to join channle, you have joined the maximum number of this channle type (Code 10017) "

I can’t do anything but click the “OK” button and logout to the game main title

My battle tag is IronMartin#1816

Hope you guys can help me solve this problem ,really want to play D3 ,thx


Code 10017 keep signing me out
#2

Same here. Are there any server issues?


#3

I am currently getting the same code right now (code10017).


#4

same here, getting same issue


#5

Same here, so frustrating!


#6

Hey all,

We are investigating the reported error. So far it seems to be an account-level error and may not be related to the local game client. Any affected users please post here!

Thanks!


#7

what is this? after maintenance i got this 10017 code that keep signing me off.
after click play get to the char screen then the code 10017 screen just block it if you click ok it will sign me out. i cant change anything…


#8

SAME HERE!

You have joined too many channels Error.

im in NO channels. changed nothing.


#9

I am getting the same problem. I see other people playing but I cannot get on.


#10

come on, this is stupid. check the old posts nothing seem to be fixing this error…
we might in for weeks of waiting…


#11

I am having the same issue atm… Nothing I have looked up has any real fix for it either…


#12

all posts include blue point to server restart which i dont think they will do that…
so glad i buy this game that i cant play…


#13

Ya I think that is the only fix. So it looks like some of us might be able to play for a week.


#14

………so dumb………


#15

Same Error here. Does anyone test these updates before pushing them to the servers? It seems not a lot of times.


#16

Same error here. can get to the character screen but it pops that error up about too many chats and then kicks me out.


#17

I can log into the other blizzard games with no problem for the American servers…


#18

i also have Code 10017 as while. was fine before maintenance and now i get the code


#19

Same error here after today’s maintenance, it worked fine before that.


#20

account level error? So how do we fix this?