XBOX Series X controller randomly disconnects

I’m using an XBOX Series X controller on a PC using bluetooth. The Controller is the latest Series X version and has the latest updates.

The controller randomly disconnects and reconnects when playing Diablo 2: Resurrected. This appears to be a problem with D2:R because it is not happening with my other games.

This problem already existed in the beta version and has not been fixed.

Please help fix it.

Thanks!

(I copied this post from the beta forum, shoutout to OP with the exact same problem)

6 Likes

I have this same problem. Xbox Series X controller. Latest firmware, drivers etc. It’s fine in menus, but as soon as I’m in game it’s constantly dropping the connection.

The same controller works fine in other games. It also works in d2:R when I plug it in via usb-c.

4 Likes

I am also having this issue.
Of note: this same controller (xbox elite series 2) works without issue in other games. Including those with high cpu/gpu/network needs. (Cyberpunk, ESO, etc).

In D2R - can’t play for a minute without it disconnecting.
First, the game will “lag out”, FPS drops to like 5. Then the controller disconnects.

4 Likes

Using a USB-C cable works.

1 Like

I also wanted to say that I’m having this problem.

I’m connecting an Xbox Elite V2 controller to my PC via BlueTooth and the controller disconnects every 3 seconds and prompts me to hit the “A” button. The game is completely unplayable with my controller connected via BlueTooth.

This is only an issue with D2: Resurrected. Games like overwatch or any other game in my library work flawlessly with the same exact setup. The controller stays connected to BT 100% of the time in any other game.

I can also confirm that plugging the controller into the PC via USB-C fixes the problem, but is very inconvenient.

I hope this is on blizzard’s list to investigate.

1 Like

Wife and I are having the same issue with identical Xbox Elite Series 2 controllers. They work flawlessly when connected with USB-C.

Same exact issue with the same exact work around (using usb-c cable instead of Bluetooth). I have no problem playing WOW with a controller using Bluetooth. On the other hand, I cannot play D2R for more than 10 seconds before it disconnects and reconnects again.

I’m using xbox controller on PC, and when I press A, the game thinks its a mouse click so changes the UI back and forth from controller to mouse UI, pausing the game completely and lagging it out making playing with a controller impossible. I can’t even use the cursor movement with the controller and can’t select anything from options menu, each time I press A. My controller is plugged in with a usb cable. Other games, it works flawlessly, but in D2R is super bugged. :roll_eyes:

SOLVED: I play D2R through steam, and some how it works perfectly without bugging out all. No more when I press A to talk to NPC or open, pickup stuff it buggs out. I works perfectly now. Hope this helps. PS. I saw this on reddit.

Well, glad you solved it, but thats a different problem.

1 Like

I’m also having this issue. Using a USB-C cable does not help, either

Hope they fix this soon. The gamepad input scheme is so much better but like this, the game is unplayable…

1 Like

In steam Add Diablo II Resurrected\D2R.exe as a external game
Add Non-Steam Games to a Library(google it)

Set default controller profile for it and run(while battle-net is running and logged)
Work like a charm for me:) No more cables
GL for you guys

1 Like

Why have to use Steam to run Diablo??
If it’s compatible with controllers, why is getting the controller dc?
With steam works, using USB-C works, but the game should work perfectly without those tricks. Need a real fix of this bug.

I agree. While its good that there is some kind of workaround (have not tested it for myself) there should be a bug fix asap. The game is literally unplayable for many people with Series X Controller. Also this bug has been present in the beta already (and I did report it there aswell). I just hope they will care more for D2R and dont repeat the infuriating cashgrab that was WC3R.

1 Like

I have this problem too, at first I thought it was just conversations but no, it drops out randomly all the time

Same problem here. In fact I just bought a Xbox One X controller, and returned it because thought it was faulty since I updated the firmware lol (didn’t try other games). But since it is happening with the new one too, just checked, and it just happens playing D2:R. D2:R works just fine with a plain old Xbox One controller. It is pretty strange :video_game::man_shrugging:

Add my wife and I to the list of players randomly dropped. It says “Reconnect Controller” (it’s already connected and nothing changed) and when you push “A,” it comes back for a second but then “A” doesn’t work.

Really infuriating because it just started after a week of working perfectly, and now it’s every hour (for both of us).

(2 Xbox One controllers in good shape, white, wired)

Mine has been doing this off and on…seems to be happening on here but not other games

Same problem here. Since today the controller don´t work at all anymore. USB-C is not an option for me. My PC doesn´t have an USB-C connection.

Same problem here with Xbox Elite Series 2 Controller on Windows 10 Laptop via Bluetooth connection.
I thought it was my controller hardware issue. But it works perfectly fine in other games.

Please Blizzard do more Compliance / QA for your games!