Keybinds keep getting reset to default

Wow, never would have guessed that would cause it! Was able to fix the issue by going into my saved games folder:

C:\Users\%USERNAME%\Saved Games\Diablo II Resurrected\

And then changing the “char.keyo” file to “CHAR.keyo”. Also did the same for “char.ctlo” file. Keybinds are now working correctly!!

Thanks for pointing me towards the solution!!

this is due the bug of capital letter, the developer team of this game is pure junk. stop hiring novice interships, thanks.

2 Likes

Hey there all,

Thanks for taking the time to reach out about this. There’s a known bug in with our developers now and they’re working on a solution. We appreciate the reports.

The original poster has identified a possible work around, but the problem should resolve itself after we push a hotfix for the problem.

2 Likes

this bug had been annoying me the past few days, thanks for the fix.

i had played Diablo, Warcraft, D2, WoW, D3. stopped playing in 2012. Just came back to D2R after watching some vids of the 2.4 PTR and was excited for Ladder.

Back when I played WoW my biggest complaint was all the errors after every patch. I mean they have over 10 million accounts @ $15 per month but they can’t proof their coding.

1 Like

no problem!! now we just gotta hope once blizzard fixes it, that my workaround doesn’t cause it to break again xD

Hey everyone!

Thank you all for your continued reports and patience with this issue. Updates for this specific issue can be found at the Blue thread linked below:

If you are still experiencing the problem, please let us know here in this thread.

I am still experiencing this issue. Every time I join new game key bindings reset to default. Not new characters. I tried the workaround of uppercase and it did not help. Do I need to do a force update or something?

Playing online, version 1.1.67554, Americas region.

Logged in. PC, Europe, 04.02. 11:19.
Keybinds reseted again, even though I was trying that workaround with the upper case letters for the keylog files.
Can you fix this ASAP? I am really getting tired of having stupid nonsense issues after every maintenance.
It is getting pathetic at this point…

It doesn’t fix it, I renamed those files using uppercase letters. And 1 day later having the same stupid issue again…
Joke…

1 Like

I am facing the key-binding issue too. As well as the character name upper-case, and the wrong ordering of the characters.

This is getting annoying… can you please fix it???

1 Like

Playing version 1.1.67554
In this version, there are NO .ctlo nor keyo files !
Here files extensions are .ctl and .key.
Capitalization is the same in all savegame files; but changed keybindings,
in my case Skills 9-12, reset on every game load.

I find it frustrating to change my custom controls every time I log in a character. I can’t even imagine how it is for a handicapped person. Let’s say like someone trying to play with one hand. You are aware of the problem. But you don’t fix it. I would think you would try to make the game as handicapped accessible as possible. Or don’t you even care?

I “fixed” the problem by renaming all char-savefiles to lowercase.
After that my keychanges persisted.

When I attempted the stated workaround, I found the files in question were already named in CAPS despite my character name displaying correctly (with only the first letter capitalized). I renamed them to match that and now it seems to be working as intended. (Will update if there are any differences with other character files.)

This is still an issue for me. I have tried all the workarounds. I have used custom key binds since forever for all my skills, this game is currently not playable for me right now. I keep logging on daily just to see if it is fixed.

1 Like

I am still having this issue, have been for many days now. I have tried all the workarounds. Playing established characters many months old, version 1.1.67554 region americas playing online. Every time I start a new game key bindings reset to default.

1 Like

still not fixed. Trying all the workarounds every day. .ctlo and .keyo files all caps, all lowercase, just first letter caps.
I’ve been playing this game for decades. Was stoked as a mofo when resurrected came out and have been having a blast but this is a deal breaker for me. I use a completely different key setup for reasons I don’t need to explain. Having to reset ever single time I join a game is a non starter for me. This is making me really sad. I feel like I’m going to get banned for posting so much but I just want to play the game.

1 Like

Just to give you guys a summary of what happened, so you’re not confused:

Char names were changed to all uppercase, causing keybinds not to save/load (unless file was renamed to uppercase). Workaround discovered and posted (with several confirmed working).

2 days later, Blizzard implemented a “fix”, which set all char names back to normal, thus breaking this workaround. Solution for anyone who implemented workaround: Put your .keyo and .ctlo files back to normal casing. Should be all good again!

You can delete the file. The game will automatically create a new savefile. That should work.