Black pixel squares comes and goes

Hey guys, I’m not sure if you can help me, but I notice big pixel squares in some areas that really disturbing, changing resolution scaling helps a bit. I tried to change some settings, nothing helps

I also have this issue. I have an Nvidia 1080ti and I am using the highest settings on Windows 11 preview.

I have a similar issue, also running win 11 preview

Can’t link to imgur album illustrating it.

Let’s make this one thread huge, so we can have more traction. This bug is really problematic in Act IV

Having the same problem here. Noticed it first in Act 2, but now it is becoming a bigger issue on Baal runs. As noted by another, it seems to occur when he flees (teleports away). A giant moving black box covers him. I also noticed it a few times in Harrogath town, so not sure it has to do with a fleeing enemy.

I will also say that I play on console as well, and I have never seen it on console, so I am assuming a driver issue.

Hope this gets fixed soon. The random nature of the bug makes it all the more frustrating.

Update: It happened on console now for me also. Hammerdin in Arcane had his hammers show up as black boxes circling him; Also, the lightning spires were shooting out a white circle aura after the circle lightning attack, almost like a white shadow. If I can figure out how to add pictures, I will attach them.

same problem
After the first act, artifacts and flashing black squares sometimes appear in the place of some monsters and in the display of item icons.

win 10 20h1
11th Gen Intel (R) Core ™ i5-1135G7 @ 2.40GHz

Intel (R) Iris (R) Xe Graphics
Driver version:
Driver date: 06/01/2021

I’ve been getting it a lot in the final Baal fight. I started an Assassin character, and every time I use Shock Web, it get the black boxes over the traps, so I have no idea what’s going on.

i still have this problem. shock web makes black boxes so i cant se whats hapening. And some enemies sometimes makes part of chreen coloure mixes. I think Diablo makes the coloure mix most.
i have turn qualety down as mutch as i could but it dosent help.

With any Holy shock, monster or character I get a constant flashing black square that drives me crazy. It also makes seeing things very difficult. Any suggestions.

Hello, I started playing with Assassin anth the black boxes still appearing whenever I throw shock web. Please help

I have the same issue green and black artifact squares pop up and cascade across the screen in certain effects, and initially when I am in the main menu i see a black square appear and disappear.

Here is the thing this game ran perfectly fine before the new patch via NVIDIA 470.86 drivers.

One day after the patch it would not detect gpu so I updated vulkan sdk and then finally tried new nvidia drivers the game then would at least load but has artifacts.

Also this newer nvidia driver causes issues with another game causing VK::waitForFence Device Lost error.

So I must choose which game I want to run properly by which driver I will run. It seems to affect people using M$ Windows as well.

I am running Linux Slackware 15 w newest feature branch nvidia driver, vulkan sdk 1.3, and other system items are up to date. Using a Lutris Profile to play d2r.

I played all of season 1 fine, then came back for season 5 and it has turned into a big headache to even play this game.

I think it might just be time to get back out my diablo 2 cdrom’s and install original and use the pack files to use Open Diablo 2 or PDP2 which ever is better and simply shelf D2R for good.

I doubt they will get around to fixing this. And downgrading drivers is no longer possible because of the new vulkan stuff this game relies on uses a newer driver.

Is there an update to this? It bugging me, I don’t see the gameplay in Act 4

For those of you running Linux, I was able to solve this by enabling Nvidia DLSS option for my GPU in the game menu.

To make it show up, I switched to Proton GE 9-5.
I also switched from dkms-open nvidia drivers to proprietary dkms drivers, but not sure if those are related.

Anyways, enabling DLSS seems to be a working solution.