Update download speed stuck at 100-300 KB/s

was having the same issues. Updates start max speed but quickly drop down to like 30kbs. A combination of starting my PC in safe mode and running scan/repair for each game got them updating at max speed again

The exact same thing happened to me. Was sad MW2 beta was gone so thought maybe cold war would help the itch. Started downloading the latest update and it was super slow. When it was done tried to launch it and I got the same error code you did. Tried everything, nothing worked so uninstalled and trying to reinstall now but its doing 300kbs mostly and sometimes jumping to full speed.

1 Like

I’ve been trying to download an update for cold war and the damn thing has been stuck at 90% for 19 hours a 2.13 kbs my normal download speed on something like steam is 60 mbps.


Same here with Cold War. Just got new 1Gbps internet yesterday, but my download is at like 500 B/s

Trying to update Overwatch.
It starts to update.
Downloads super slow. And after 1-3 MB it stops.
“BLZBNTAGT0000138F” < error code which provides 0 info online

I think it’s a battle.net problem - I uninstall it, reinstall it, nothing
I think it’s an Overwatch problem - I don’t tell battle.net where the game is, and let it install from scratch. same thing. “Downloading update”

I am on a VPN. I tried switching IPs.
Tried changing DNS.
Tried a different connection.
ipconfig flushdns and all that stuff, I did it
Battle.net as administrator - I’ve done it
Deleting indices folder, deleting .idx files, etc - I’ve done it
^ And related to this, I think it’s important to mention:

i also tried “Scan & Repair” (overwatch files)
it starts scanning but then stops, giving me the same error.

I have a big big feeling that it’s connection related.

Some logs that you may find interesting:
Network Connection Response to http : // eu (dot) patch (dot) battle (dot) net : 1119 /agent - CURL error: 0, Status Code: 404

[d:\package_cache\tact\df56f62\src\async_state\async_cdn_index_read_state.cpp:477] Downloading CDN Index: ‘5b8027f048c80d40555ba48c510b638f’.
[I 2022-09-18 13:25:09.0194] [tact][d:\package_cache\tact\df56f62\src\async_state\async_cdn_index_read_state.cpp:477] Downloading CDN Index: ‘774501649e7718c44519a9811a9769dc’.
[E 2022-09-18 13:25:09.0278] [tact][d:\package_cache\tact\df56f62\src\download\cdn_index.cpp:347] Invalid CDN Index file size. Expected 1297828 bytes, but got 1964953.
[E 2022-09-18 13:25:09.0278] [tact][d:\package_cache\tact\df56f62\src\async_state\async_cdn_index_read_state.cpp:560] Retrying download for CDN index with key: 0957b173bd4a843018394b8c85a632e8
[I 2022-09-18 13:25:09.0279] [tact][d:\package_cache\tact\df56f62\src\async_state\async_cdn_index_read_state.cpp:477] Downloading CDN Index: ‘0957b173bd4a843018394b8c85a632e8’.
[E 2022-09-18 13:25:09.0417] [tact][d:\package_cache\tact\df56f62\src\download\download_curl.cpp:1003] cURL request failed with 18 : Transferred a partial file
[W 2022-09-18 13:25:09.0417] [tact][d:\package_cache\tact\df56f62\src\download\cdn_download_request.cpp:43] Download request for 68610f0a459675b25806ddabe9505a1e(0, 0) failed with HTTP code -1
[W 2022-09-18 13:25:09.0418] [tact][d:\package_cache\tact\df56f62\src\async_state\async_file_download_state.cpp:199] Retrying download 68610f0a459675b25806ddabe9505a1e(0, 0) due to failure. NodeId: 4 : HTTP code: -1
[E 2022-09-18 13:25:09.0567] [tact][d:\package_cache\tact\df56f62\src\download\download_curl.cpp:1003] cURL request failed with 18 : Transferred a partial file
[W 2022-09-18 13:25:09.0568] [tact][d:\package_cache\tact\df56f62\src\download\cdn_download_request.cpp:43] Download request for 14a2cf67aa878f795971bf361d4b68be(0, 0) failed with HTTP code -1

[W 2022-09-18 13:25:09.0568] [tact][d:\package_cache\tact\df56f62\src\async_state\async_file_download_state.cpp:199] Retrying download 14a2cf67aa878f795971bf361d4b68be(0, 0) due to failure. NodeId: 5 : HTTP code: -1
[E 2022-09-18 13:25:09.0819] [tact][d:\package_cache\tact\df56f62\src\download\cdn_index.cpp:347] Invalid CDN Index file size. Expected 1091828 bytes, but got 1616262.

so constant failures when it comes to downloading. http code is ALWAYS -1, nodeID varies.


I currently have the same issue with Call of Duty Black Ops Cold War. It’s taken 2 days to update with an average of 25kbs per second, then it crashes and sets that error code. I have done evereything you mentioned above as well, I have a 1 gig upand down connection and don’t have issues downloading from any other source.

Just re-downloaded Battle.net again after a long time to download Wow.
Very similar issues to u, except I don’t get any error. The download speed is agonizingly slow at 50 kb/s when the internet can provide 300mb/s upward of download speed.

Have tried every solution I can think of, even gave Battle.net and my laptop internet priority in router settings. No avail.

Seems like this is a blizzard server issue.

yeah, think i’m going to be avoiding getting anything from Battle.net for a while, they are still refusing to fix their server, going on 3 days since they messed it up with mw2 beta, going to be getting mw2 on console or on Steam this year.

fixed it, i appreciate it man.

so this error still is still alive …
waiting now for ages get the battle net app installed.

what a bad …

1 Like

I got this problems for months now, glad to see im not alone… Tried everything being said here, nothing working. Plus, when trying to download my wifi just shut down, have to close battlenet, turn off my wifi on my pc and turn on to be working again. Tried to with cable, same happening. I guess i’ll not playing MW2 for now :frowning:

The exact same thing happened to me

Hey guys i found a solution… MW2 available on steam :joy:


Go to settings > downloads > limit bandwidth > uncheck this box. Usually there’s a limit on the pre-released content.

It’s a Blizzard problem. They just don’t want to spend the money to fix their service. Current download speed is 3.52Mbps. My friends bought their game on Steam and have been playing for 45min already, and I will have to wait until tomorrow to play. Most people have high speed internet now days, maybe you could consider supporting it?

FYI, I have updated 4 games on Steam at a rate of 60 - 276.8Mbps. All done before I could get to 39% on Blizzard.


I also have the same issue. Stuck at 1.5Mbps when my normal download speed is 100+Mbps. I tried the region change, tried uninstalling/reinstall, even reinstalled windows. Tested opening ports and just about everything I could find. All I can think is that the app is fundamentally broken so the updates aren’t able to use the full internet speed.
The worst part is they wouldn’t even allow me to refund my games so I can buy it on steam so instead I have to deal with their broken app!


Battlenet/Blizzard/Activision - FIX YOUR SORRY A$$ Launcher and its broken download speeds. You take people’s money and offer trash for “TIPS” or “QUICK FIXES” that don’t address the issue. YEARS this issue has existed and yet you do nothing to fix it. I don’t know why I bother buying games on this launcher. I think I need to stick to Steam from now on. I should have learned by now.


I will personally never buy anything from this company again i have tried changing my dns server scan and repaired the game which took ages for no reason and the only tip the have is to unlimit their download speed which does absolutely nothing if the game isnt on steam im not playing it. it is unacceptable that a AAA company cant fix or even address how bad their launcher has been for years


Never buying anything off this launcher again, absolutely ridiculous how long I have to wait because of this launchers download speeds. I could download 1000 gigs of video games off steam in the time it takes me to do this 50 gig mw2 update.


500 MB/s internet speeds and I’ve been stuck at 300Kb/s for 2hrs