Unable to open BattleNet Desktop App

Have been trying to open up the Desktop app but after logging in, before anything loads and after the window itself opens, it crashes and prompt a report screen with “07846537-916C-464E-BD91-2AAB7B98447F” as a report code.


did a restart
reinstall and a restart
going into %app data % now looking for anything else

Yeah, restarting my computer and reinstalling app were my first two reactions.

any ideas how to fix? ive both restarted and reinstalled but neither of those have helped.

Having the same problem here.

I just opened Bnet app as ‘‘ADMIN’’ then it worked o.o

I tried that, no dice for me.

no idea yet
did a APPdata clear and a localappdata and it comes back has to do something else…

Localapp has the old cache… so… im confused now maybe ill do a uninstall and wipe the app and local app … but … i need food

1 Like

yeah i tried opening as admin after the other two ideas and it didnt work for me either.

Same issue for me. Just keeps crashing and throwing different errors

Also experiencing this issue, never the same error code for me

Also experiencing this tried all steps above

looks like there is now a wait to get in must be server side issue

still isnt opening the app for me at all without closing out with the same Blizzard Error and asking me to describe it and to use a request code. ive done everything i can possibly think of. if the servers were just full, thatd be something id just wait on, but it wont even give me the chance to try lol.

same for me, tried reinstalling and restarting and nothing. even updated driver w a restart and still nun some one please help

Blizz needs to be more proactive with this kinda stuff. I mean, they almost never are. It probably doesn’t help that all of that stuff happened with them recently. Still, I feel like if they actually cared, they’d have had employees be the ones to start this chat and be working and communicating with people about what’s going on. But ya know.

Id like a reply at least, even a copy paste reassurance that they are looking into it. For all i know nobody at Blizzard has seen this yet.

1 Like

That’s what I’m screamin’.

not sure if I fixed it or they fixed it on their end

did a uninstall
deleted C:\Users\yournamehere\AppData\Local\Battle.net folder did a re-installed now im connected.

edited added full path

1 Like

Looks like they did something. Tried logging in after reading your comment and it works.

1 Like