Stuck "Updating Blizzard Agent"

Process gets stuck at about 35% trying to fresh install battle.net after uninstalling it a month ago.
My laptop, which is hooked up to the same router, has no issues with battle.net OR running any Blizzard Games.

I have tried:
-Uninstalling Battle.net app and reinstalling as Admin
-Opening Various Temp locations and deleting Battle.net and Blizzard Folders
-Disabled Controlled Folder Access
-Restarted Router
-Performed ipconfig /flushdns, ipconfig /release, ipconfig /renew
-Full Network Settings reset
-Creating a new admin account and attempting install from there
-Not using any sort of VPN and not using a Proxy server for LAN
-Bringing over a fresh Battle.net install from my laptop and tried to run it on my desktop (gave a completely different error where it brought up the sign in box but did not have a “sign in” button to click after user/pass was entered…)
-Full Windows 10 reinstall and update
-No 3rd party security software

1 Like

Hey there! Thanks for reaching out with that detailed information. If the problem has persisted through reinstalling Windows, it’s highly likely that the issue is network-related. Does the install move along when testing an alternate network?

If you’re able to finish the installation when using an alternate network, that tells us the issue is isolated to the network that you are currently using. If this is the case we can only recommend contacting the ISP for assistance determining what is causing the issue to occur on the home network. They may adjust specific security/firewall settings on your modem or temporarily replace the device to narrow it down further. Keep in mind that you can request to speak with a “level 2 or level 3 technician” when contacting the ISP, as the front-line representatives typically only have access to basic diagnostics and troubleshooting tools.

I hope this helps!

1 Like

Issue was resolved by switching to a new router.

Hi, I have just bought a new pc and have encountered the same problem
Have tried every bloody thing to fix it. You are joking when you tell me the only way to solve this is to buy a new router

1 Like

Hey guys, I have similar problem after trying to install the COD Modern Warfare patch. After I deleted the battlenet app I cannot install it again due to the stucked “Updating Blizzard Agent”. I have tried all possible solutions including switching to an alternative network, deleteing all battlenet/blizzard related files, disabling windows brandmauer etc. Could someone please help me to solve my problem.

P.S. I am launching the setup file as an administrator.

2 Likes

Hello, i have same problem. I deleted battle.net because it wouldnt update diablo3. And i tried install again, But i stuck ad “Updating Blizzard Agent…” . Help me, i cant installing app

2 Likes

Hello.

I have problems with installing battle.net app on fresh windows 10. When i launch setup i get stuck at Updating Blizzard Agent ( 2/5 finished ).
I tried almost every solution i could find in your support page and nothing helped.

2 Likes

Hi,

I have the same issue as everyone above. Tried basicly every solution there is, new ip adress, new router, even tried using my phones internett. Have also tried to delete all and reinstall, same problem. Right now im out of options.

3 Likes

same problem here, just opened a ticket

1 Like

also struggling please do smt!

I tried vpn but still same. I see some people have same problem, i read it everything. I already deleted files in programfiles or appdata or somewhere… But still same.

If you tell me restart my modem, i can throw my mouse outside…

2 Likes

something borked at blizzards end: also changed hyperlink in error log because forum was complaining to hoattp

E 2020-06-30 15:28:43.164810 [Main] {3d54} Network - {3d54} ERR (d:\buildserver\bna-2\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\net\source\net\standardnetworkimpl.cpp, line 345): poll error: NET_ERR_FAILURE
E 2020-06-30 15:28:43.164965 [Main] {3d54} Downloader - {3d54} ERR (d:\buildserver\bna-2\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\downloader\source\downloader\standarddownloadserverset.cpp, line 369): name resolution failed for server URL prefix ‘Hoattp:us.patch.battle.net:1119’: NET_ERR_FAILURE
E 2020-06-30 15:28:43.165130 [Main] {3d54} Downloader - {3d54} ERR (d:\buildserver\bna-2\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\downloader\source\downloader\standarddownloaderimpl.cpp, line 897): failed to select host for download 1: DOWNLOAD_ERR_NOT_AVAILABLE
E 2020-06-30 15:28:43.165238 [TactProduct] {3d54} Download error - DOWNLOAD_ERR_NOT_AVAILABLE
W 2020-06-30 15:28:43.165366 [Main] {3d54} Downloader - {3d54} WRN (d:\buildserver\bna-2\work-git\bootstrapper-repository\contrib\contrib\bnl_dl2\downloader\source\downloader\standarddownloaderimpl.cpp, line 1693): unclean shutdown: ~ActiveDownload() not called from network thread

Same issue here. Latest Mac OS, tried all tips from support articles, even different network. I can post the logs, but from what I see you broke your backend the installer try to connect to…

2 Likes

Same thing here. Judging by the amount of people coming up with this in last ~2hr I’d say something’s wrong on blizz side right now

same here, im now more calm because i see a lot of people have this issue. Tried everything

I am stuck at install too.

I was stuck install. After i saw a video on youtube, and i deleted all folder in %appdata% or programfiles or everywhere… And i stuck “updating blizzard agent…” now… hell its so annoying. Steam is working good but looks like blizzard server have a problem with updating.

I wish i didnt delete app but i had to

2 Likes

Same issue here, I tried through Ethernet and WIFI, I tried different connection on mobile hotspot and I tried every single step on youtube, but still showing same thing “Updating blizzard agent…”

Please help!

Same problem. Reinstalling Windows didnt fixed anything.

Same issue, had to reinstall the app because it suddenly lost all the installed games & couldn’t update them (or so it said).
Now stuck at installing.