Spells api returns 404 responses for a lot of spells

A lot of spells such as those from azerite gear (selected azerite spells) and lots of other base spells return 404 responses when using the spells api. Spells from talents and pvp talents seem to work but not base spells for a given class.

For example
/data/wow/spell/255937?namespace=static-us&locale=en_US (Wake of the ashes) works
but
/data/wow/spell/20271?namespace=static-us&locale=en_US (Judgment) does not. Returns a 404/BLZWEBAPI00000404

Similarly for other classes as well. Tried warrior spells, talents/pvptalents seem to work but base spells return 404 responses.

All azerite power spells also seem to return 404s, example /data/wow/spell/263984?namespace=static-us&locale=en_US (Elemental Whirl)

4 Likes

I’m having the same problems. In addition I can’t find a suitable way to collect a list of all character abilities with the new API, I am building an ability recommendation system that requires a list of all abilities.

Could someone help me with the process to get this list ?

Thanks, stay safe inside !

Greetings all,

We are looking into this issue. We believe this currently affects all spells which are not referenced from other sources, such as talents, recipes, etc. This includes class base spells, such as “Judgment”.

Thank you for the report and for your patience as we investigate.

4 Likes

I am also running into this, trying to look up icons for spells from SPELL_CAST_SUCCESS in the combat log.

Around 90% of spells players cast are 404ing. If I look up the spell IDs on Wowhead they are listed as expected.

Agree talents/essences tend to work, but basic class abilities don’t.

Also got this for spell and spell media from spell gathered from azerite power.

Also not showing for mount spells, e.g. Dawnforge Ram (270564)

Is there any new about this topic? I’m getting errors on traits and corruptions icons

Bump, still a big issue

Any update on this? Would love to get info on these spells…

Any updates? My app is still not able to show some spells, and as requests are failing, I cannot cache them, so I’m consuming requests’ bandwidth :S