Something went wrong (Difficulty retrieving content from our servers)

nothing has worked for me. When it used to work, battle.net would open and it would start loading the part where it used to show the latest whatever but now it just loads for a few seconds and then says “something went wrong” and below that it says “We’re having difficulty retrieving content from out servers. Please try again with the button below.” and the button says “reload”. It has been like this for roughly a month now and it is like that on any games news stuff thing. maybe the guy whose working on the mobile diablo app is working on the blizzard battle.net app. If you don’t have a answer to this problem then don’t reply dumb fixes that obviously don’t work. Let a Blizzard employee reply if they even exist anymore.

Still having this issue as of 7/23/2021 @ 11:20 PM. “Whoops! Looks like something broke. Give it another shot.” The error message I get every time. This is the first time I’ve dealt with this, and I’m sure it wont be the last. I’ve uninstalled and tried reinstalling for the past 2 hours, only able to download the battle.net client. All the other games refuse to work, or download. This isn’t on my end after reading all of these forums. I’ve tried every option available. Please respond with something, or fix whatever issues you guys are having.

thanks this worked for me and nothing else did

I have this problem.
It started today as soon as I activated the authenticator.
I have never seen the error prior to that.
It is not an issue on my end.

Edit: Also, if I open battle.net app without logging in it works fine.

Edit: ok. So I enabled the ‘always require authenticator’ in my account security settings and it appears to be working again.

I think I may be able to help everyone who is still suffering from this annoying problem.

This problem started for me when I recently changed my Blizzard Account’s registered Email Address. I couldn’t work out what to do and how to fix it. Then I randomly updated my password and BAM! instantly the issue is fixed. It makes me think maybe my previous email/password combo was exposed in a recent password security leak and Blizzard detected this. All I can say for 100% certain is as soon as I changed my password the issue vanished. Give it a go folks!

1 Like

battle net app NEEDS to be fix ASAP im sick and tired of getting DC from blizzard server C’mon now …first WoW now COD or any other game???

omo,
did not expect this solution to work but it did o.

1 Like

Very Very thanks this worked for me toooo

1 Like

hi, just want to add some information about what i did to fix this, it happens after i activated 2FA using Blizzard Authenticator, turns out logging out and then relogin to the Blizzard App (now with 2FA enabled and authorized via the Authenticator), it fix itself.

it works really easy really fast EVERYONE DO THIS