New API: Vashj'ir Seahorse mount is missing

Hello! I am currently working on updating my web site to use the new Profile APIs instead of the old Community APIs. I am running into many issues.

I have noticed that the Vashj’ir Seahorse (ID=373, SpellID=75207) is missing when retrieving a character’s mount collection. The mounts index, however, DOES contain this mount.

  • /profile/wow/character/drenden/shoogen/collections/mounts?namespace=profile-us
  • Notice in the list of returned mounts, the Vashj’ir Seahorse is not found
  • /data/wow/mount/index?namespace=static-us
  • Notice this time that the mount is in the list

Thank you!

2 Likes

I noticed the same thing for what it’s worth.

1 Like

I noticed today that it appears the Vashj’ir Seahorse is properly showing for some characters, but still not for others. I’m not sure if this behavior has changed, or if this is just something I didn’t catch previously.

Working: /profile/wow/character/stormrage/ryken/collections/mounts?namespace=profile-us

Still not working: /profile/wow/character/drenden/shoogen/collections/mounts?namespace=profile-us

Thank you!