MW3 not showing in library

I bought MW3 its said its in library but it is not and no way to install it. This is BS i shouldnt have to do this to play this game.



Modern Warfare 3 is included as an option in “Call of Duty”… the 1st screen shows the installation folder and game language and some other options. The 2nd screen shows what will be installed… except for the Base Game, I think everything else is optional. For example, if you don’t need Warzone, I think you can deselect it.

Click on the arrow to the left of MW 3 and ensure “Campaign” is selected… then click on “Start Install”

Good luck in your games !


How is this logical? And also the option to pre-purchase is still available. Really nice user experience, thanks Blizzard!

1 Like

This did not work. There is no dropdown arrow. When I check the box to select the install file for MW3 it will not install

1 Like

That’s odd… I don’t know then… the other player I helped with this had no issue installing it once he clicked on the Start Install button.

MW3 is in the library, but it says I need to pre-purchase, when I already pre-purchased the Vault edition of the game 11-Oct!!

Worked for me. Thank you.

1 Like

Worked for me just now!!!, exactly how u stated it. Just bought this on PC today 11/2, the standard edition, and it didnt show up in my library, but clicking on the regular “call of duty” tab, click install, the first page will be where u want to install it and what language, and then the next page will be which call of duty u want to install. Good luck!

1 Like

Worked for me, but really, as if the way they name them wasn’t confusing enough anyway.

1 Like


Thank you for reporting that it worked for you.

Yes… and even Activision is having troubles with this. Their webpage on MW3 installation says:

Installation on PC

  1. Launch the app and log in to your account.

  2. Select All Games.

  3. Find and select Call of Duty: Modern Warfare III.

  4. Select the Install button to download and install the game.

Well… the “All Games” button no longer exist on the Battle.Net App – it was replaced with “Games” some time ago.

But then it instructs to “Find and select Call of Duty: Modern Warfare III” ? Like WOW !!! didn’t they check that before writing it ???


this didn’t work for me but i figured out how to get it. I had to uninstall cod and battlenet. after reinstalling battlenet i went to install cod and thats when i got the dropdown list

1 Like

Just switch the blizzard app to beta and the drop downs should come back. It’s on blizzards end not Activision.

This is absolutely ridiculous. spent a hundred dollars on a game that from what I can tell isn’t even showing up in my games section on blizzard. guess I’ll try uninstalling battlenet.

See my post above: MW3 not showing in library - #2 by Boubou-1741

From the Activision website on how to install MW3:

PC players: Call of Duty: Modern Warfare III uses the Call of Duty HQ to launch the game. When downloading or launching the game, look for Call of Duty in the store or your game library.

So… have you tried installing “Call of Duty” ?

1 Like

this worked for me as well, they tried to make it easier to access all titles however seems everyone is getting more confused then ever.
Anyway thanks for the help

1 Like

Same issue I just got a refund, after messing with their stupid website verification for 30 minutes, and bought it on Steam. It showed up in my library without any stupid steps. Blizzard sucks.

How a company of this magnitude has such a ducking retarted system is beyond me.

I just purchased cod mw3 through even confirmed in transaction history. when i go back to try and find download it is still asking me to buy it! Anybody have any ideas? It doesn’t show up in my library at all.

I see - so it may already be installed. Modify Install of “Call of Duty” and make sure Modern Warfare III is selected.

Still the same issue, says the games in my library but it isnt.

The call of duty game has no drop down or options to select MW3 to install.
wtf is going on