Mw2 wont launch possible fix

Okay so after a month of trying to get this game to launch on pc, doing all the steps from moving folders, running as admin, switching drives, disabling firewall/allowing app through firewall, scan and repair(useless btw) downloading a different language, reinstalling battlenet, renaming the folder, windows update, updating all drivers, rolling back gpu driver to 5.69, deleting the files from “my documents” EVERYTHING UNDER THE SUN!!! I tried something… I had an old asus motherboard with an amd a10-6700 and installed it into my case using the same SSD and gpu, guess what?? THE GAME LOADED RIGHT UP!! so if I had to guess my CPU/Motherboard(xeon x5690 with 32gb ram/gtx 970 wind-force) isn’t supported to play this game that I paid $107 for! unfortunately that old board/cpu wont play the game at all with how outdated it is, BUT IT WILL LAUNCH. and supposedly my setup had all minimum requirements to play MW2 so I dont understand. The Sad thing is with all these posts on here and Activision support pages, not a single fix and or response from anyone. tons of people paid for a game they cant play. please fix this!!


Me and my father did the same thing but not with replacing the motherboard and all. We downloaded it on the crappiest laptop alive and it launched too. And it’s highly possible our mother boards aren’t supported. So i guess we’ll have to wait till 16 november and hope the patch for this sodding bug comes with it


God I hope so!! because I have no problem playing any other game! MW, WARZONE , COLD WAR, FORZA ETC ETC. I downloaded the WARZONE 2 last night and still wont load.

1 Like

anche a me non accede e neanche mi fa giocare a warzone…sembra abbia sostituito i file in attesa del 16 però la trovo una cosa assurda non poter far più giocare i giocatori prima del tempo!!!

I am having the same issue cant believe I paid over $100 for this crap

I contacted Activision with no response from their end. I really just want my refund at this point. I find this odd as call of duty modern warfare 1 worked fine through but call of duty modern warfare 2 cant even launch even after update wtf. I currently run it on my asus strix rog gaming laptop never had this issue with other games.


Same for me. tired everything and after reading the posts hear, I am glad I didn’t wipe my computer and start over. What is irritating is that this has been going on for over a year now. Just stopped after an update. I may have an older MB with an i7 4770k, but this build hasn’t hit any limitations on any other games I am playing except COD. Same goes with Warzone 2.0 . Hope someone take a look at this post and decides to get something figure out.


Here is possible solution it worked for me. no thanks to activision

I had the game running right after i bought it. I had to reinstalled Windows and now after 3 weeks+ i can’t run it.
On my other PC we got it as well, didn’t work even after trying everything. I reinstalled Windows and then it worked. So i thought it would be fine on my other PC, but NO.
The Allen ticket guy from Activision ask me all my info, got to me once and then nothing…

DIdn’t work for me and its on x86

Same boat here, the funny thing is that they fudged Warzone 1 and they have 0 Customers service, i was contacted by a tech Allen guy, but he wasn’t the key to my issues…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.