Installer says "calculating size", will not start download

Hi, at the bottom left of the window it says Calculating Size and has a spinning blue triangle beside it. The button on the right says Install but when I click it the words change to the spinning blue triangle thing and nothing changes for hours at a time.

multiple installer launches and computer reboots over the past 3 days. still the same result every time I try to download

how can I get this game?

12 Likes

Hey, recentlyafis! Is this with Mac? Usually, the “calculating size” is a mac related message. It could mean that the drive is corrupted or malfunctioning usually, or a third party application was used to try and install the file. Are you having this issue with installing a specific game?

This is on Windows 10 Pro 64 bit
Trying to download COD Modern Warfare
I think its trying to calculate the size of the download not the storage but I dont know for sure
I’m trying to install from the Blizzard downloader

4 Likes

Hi, I have the same problem and I’m using windows 7 64 bit, had this problem for a while now, i cant install any games at all. it just stays stuck at the ‘calculating size’ sub screen.

1 Like

Mine is also doing this on a brand new windows laptop :frowning: I have tried uninstalling the app but to no avail. Has anyone been able to fix it?

2 Likes

I’m having the same Problem

Hey y’all,

The calculating size message typically indicates that another program is blocking the Blizzard app from starting the install. Try disabling all other programs temporarily. If this persists, you may need to disable or uninstall security software and restart the PC. You can always reinstall that security software again once this is resolved.

5 Likes

YES I had the same Problem but I figured it out. U have to download the actual battle net client and start it , u will see all the games they have, go to warzone and download then where calculating size used to stand there will be a green tick and 74gb something like that. Try this

44 Likes

Same problem (Win10)

Fixed - manually created installation folder, installed normally

Had the same problem then I went to the window icon went to blizzard from there and hit install also my spyware asked for permission to install

3 Likes

okay so can we just sum up all the solutions we have found so far? cuz im having the same problem. the customer support guys keep insisting it’s a problem with my internet while it’s not. it doesn’t work for most people at this moment.

1 Like

I had the same problem when I tried to download the game from the website. Just close the “calculating size” windows, open battle.net app and download from that app. Problem solved.

17 Likes

This worked for me too. Thanks.

1 Like

I am also having this issue. Should I delete my old Starcraft files or will the new installation install over them or delete them?

1 Like

Hi i found a solution to this problem try run blizzard as administrator it works for me

3 Likes

this worked perfectly really easy too thanks

I just closed the installer, opened battle.net again, and then find your way to the Warzone install on there which looks different. Then it will ask for your age and after that it just starts installing. Worked for me.

1 Like

Thank you for the fix. I can confirm, what worked for me was closing the app reporting ‘calculating size’ and then opening ‘battle.net’ found within your windows start menu.

1 Like

So easy but it works immediately thx

Hi all just to make this a bit clearer:-

  1. Install the battle.net launcher. You’ll see all the games down the left side.

  2. Click on the shop and look for the game. it’s with all the other games but shows up as free, click ‘play for free’.

  3. Go back to the first screen. There may be a sale banner that you have to close (this caught me out and i went round in circles for ages). Click on the ‘install’ button and take it from there. It needed 86Gb for my initial install

  4. Good Luck

5 Likes