[Fixed] Battle.net Mobile App (Android) stuck in login loop

I have raised a ticket however the proposed fixes (clearing cache in App and login page, uninstalling/reinstalling, restarting device, I have no ad-blockers knowingly installed on my phone) have not worked and the recommended action from Blizzard support was to raise a topic here!

When I open the app I get the login screen, enter my battle.net username password (as I do anywhere I need to login to WOW “stuff”) and I get the infinite cycle of login pages with multiple chrome windows opening on my Android phone. Very occasionally I get a Authenticator request (I still have Authenticator installed as clearly the Battle.net app is not fit for purpose) which I approve but nothing happens.

This is very frustrating, as several uses have mentioned in these forums already, as we are being told that Authenticator has moved to Battle.net but obviously this is going to be useless (and not secure) if I can’t actually login to the app.

So at the suggestion of the Blizzard Support ticket - here is my post! Has anyone been able to resolve this issue? I have seen posts about amending the URL but I can’t do this as the login page opens in a Chrome window which I cannot amend the URL.

EDIT For those interested I managed to resolve my issue (partly with support from Blizzard but only in passing); I was (again) advised to clear my cache etc but this time I noticed that Chrome had been replaced as my default browser (I have Avast AV which had installed its own browser and applied as default). So I switched my default browser back to Chrome and was able to login to the app and activate the Authenticator in the Battle.net Mobile app. So working for me (for now).

1 Like

I came across this looking for the same issue happening on my tablet. If you’re using brave browser, turn off the shields at the login screen. Avast’s browser probably has a similar functionality and that’s what caused the OP’s issue. Reading this led me to the answer.

Confirming I had the same issue until I switched my default browser to Chrome. It seems the mobile Firefox app has issues and I only use it because you can use the Ublock Origin addon with it.

1 Like

This problem still exists and switching to default browser does not fix it.

1 Like

Yeah I was having the same problem here. But I managed to make it happen by when I got the agree page, i clicked on the dots at the top right and asked it to open it in Chrome browser instead of whatever it was opening it in. And I had to accept twice, but it got me through! Hope that helps someone.

Same problem here. I had to go to settings and changed my default to bing, try to log in, went through same cycle, but then changed back to Chrome as a default and finally seemed to work. The strange part was, when i was trying to log in via Bing, I received an approve on my 2FA and was able to allow. I also turned my Wifi of and went to cellular, but have the same provider. So not sure what part fixed it, or Maybe Battle.net did something to fix their issue in the background at the same time of me troubleshooting. A friend of mine had the issue at the same time, but he keot trying and going through the cycle till it worked.

Hope this helps someone

Found this while also searching for help. To no one’s surprise it was absolutely no use going through the support articles. Encountered this issue on my Samsung Note 9, (Android 10). My default browser was set to Firefox because I detest Chrome. Set it back to the default Samsung Internet browser and this did the trick. What a sad excuse for an app in the year 2023. At least there was a workaround. Too bad it wasn’t in the support articles :roll_eyes:

Anyway, thank you for noting what worked and hopefully my input helps at least one other person.

1 Like

Experiencing this right now. This is absolutely terrible, it doesn’t make the process any safer if I have to enter and send the password numerous times. The setup in this manner takes way too long. And to be honest I expected that, I knew why I didn’t want to set up the app, and my expectation was fully fulfilled. You haven’t made it a slick and easy process, it’s a nightmare for imagine someone with disabilities, unbearable to be stuck in this endless login loop, nothing goes, not straight-forward, hate it.

E.g.: Why does the battle-net mobile app, which itself is the authenticator, ask me for the code from the authenticator, when logging into it (the mobile app), when it isn’t available. ??? why is the authenticator not able to be used in the background then

I found this thread through google since I finally decided to sit down and try to fix this annoying issue

I was using Firefox before and it would stay stuck on logging in

I set my default browser to Chrome and was able to login just fine


Thank you! I was in this exact situation, and this fixed it.