Error - Memory could not be written

For the last few months, nearly every time I shut down my computer, I get a memory error thrown by the desktop app on the shutdown screen, stating that an “instruction at X address referenced memory at Y address”, and that the memory could not be written. Examples:
ibb (dot) co/9vfX5S4
ibb (dot) co/8B9rL1n

I was hoping it would be fixed, but after several months it continues to recur over 90% of the time I turn my PC off. It ONLY occurs with, and ONLY when shutting down the PC. It never occurs when closing manually, and never occurs with any other application when I turn my PC off.
I’ve tried running system file checker (DISM in Win10) and Windows Memory Diagnostics, and neither reported any errors, yet the problem continues to persist even after reinstalling the desktop app.

It is concerning to me because I worry that the failure to write may be due to some sort of error on my system drive(as well as the annoyance of having to wait 10 seconds every time after clicking shut down in order to actually turn my PC off), and if I can’t stop the error from occurring, I would at least like some kind of reassurance that it’s simply an issue with the desktop client, and not a hardware fault. If the issue is a hardware fault, I would only have a limited time to diagnose it and submit a warranty claim.


I tried submitting a ticket on the issue, Ticket#US79115229, and running through all the suggestions offered. Despite deleting all temporary app data and reinstalling, turning off all non-Microsoft services and all startup programs, and even trying to run just the app on a brand-new admin account, the problem continued to recur the majority of the time I turned the computer off or signed out of the system account. There are occasional times it does not happen, for reference, though I can’t establish any cause for it happening or not on a given sign-out.

While I will just start to close the app before shutting the system down in the meantime, I’ve never had to close background applications running in the system tray before shutting down before. I’ve always closed any open windows, but things like nvidia control panel, dual monitor tools, steam, windows security, et al. all shut themselves down fine from the background when the system signs out.

Tried everything we could to ensure the issue wasn’t caused by some sort of system configuration, I uploaded my MSInfo file incorrectly on this post but the correct one should be attached to the ticket I mentioned. If there’s any further info I can provide to help narrow down what is causing this bug with the app, just let me know!