Diablo II video errors

Installed Diablo II on windows 10 pc installs fine starts fine. Video is flashing in a six box sequence amd unplayable. Known fixes?

Hey, shorty8641! There’s actually been some reports of similar issues that we’re looking into. Would you happen to have an AMD card or an AMD RX 5X00 XT card? Which drivers are they on my chance.

Could you try seeing if Windowed mode works?

  1. Right-click the Diablo II icon and click Properties
  2. Click the Shortcut tab
  3. Add -w to the end of the Target.
    For example: “C:\DiabloII\Diablo II.exe” -w
    Note the space between " and -w
2 Likes

I am having the same problem and tried using that solution it gave me a message saying
The name ‘“C:\Program Files (x86)\Diablo 2\Diablo 2.exe”-w’ specified in the Target box is not valid. Make sure the path and file name are correct

Put a space before the -w.

For example: “C:\DiabloII\Diablo II.exe” -w

I’m having a similar issue. Game installed fine and the Blizzard intro splash screens seem to play fine, but the main menu doesn’t work. Tried numerous compatibility mode settings with no luck.

AMD RX 5600 XT with Adrenalin 20.11.11. I just noticed there’s an updated driver released 12/8 so I’m going to try that.

I hadn’t yet tied windowed mode, I’ll give that a try too.

Edit: worked on windowed mode! Is this the only work around?

got the same video and even tried the exe -w and i breaks the app to not load, r5 1600, amd 5500, 32ram all updated even game2

You can try the glide wrapper route. I use it, I think it looks better. It’s worth a shot:

1 Like

the -w breaks exe and the wrap didn’t work looked the same 6box sequest flashs

For clarity, the “-w” gets added when you go into the short cut properties via right click properties on the shortcut, then add it to the very end of the “Target” line outside of the quotes. You do not add - w after the .exe extension of the short cut name. Note there is a space between the end of the quotes and the “-w”. See this image: https://i.imgur.com/4KxpNKo.jpg

I had what sounds like a very similar video issue as you, and windowed mode worked for me. But a 800x600 window in the middle of a 2k 27" monitor is not ideal, so I’m going to look into Sven’s Glide wrapper. I also have a friend who had luck with windowed mode and changing windows text size scaling to 150% which he says made the window larger, but the wrapper seems like a better solution to me.

EDIT: Installed Svens and it’s working great! Thanks for the tip @TheDarkJedi !

Hello,

When I start diablo2 it appears minimized and i cannot maximize. It occurs sometimes and other times it works correct. I don´t want to use the -w option. I execute as admin and compatibility with windows xp SP3.

Any idea to fix this issue??

Thanks

I followed [TheDarkJedi] instructions and it runs in full window. But now the game appears windowed inside the full window mode. Is it possible to have the real full window mode? I have tried editing glide wrapper but there is no change.

Thanks in advance

you could try running it in software mode. it works for me even in windows 10 that way.

How can i run it in software mode?

start up video test from the star menu under diablo 2 and when the test concludes, select the directdaw option.

i don´t know where is the start menu and i cannot start the video test to select the directdraw option. Maybe the problem is the battlenet installer

you are clearly from eastern europe. not that it matters, as i will help anybody. if you for some reason do not have a start menu, you can go the folder that you installed diablo 2 in and double click on d2vidtst.

You are right. I´m from Spain. And that file that you said (d2vidtst) is not in my folder. Maybe i can download it or the start menu that you said. Maybe is a problem of the d2 downloader from battle net. Thanks for the help. :slight_smile:

sorry, i did not know that they had removed it. all it actually does however is that it changes the registry. to change the registry without it you need to run regedit. go to hkey_local_user, blizzard entertainment, diablo 2 and videoconfig. find the one that say render and change it to 0.

Ok it works … million thx for the help and your time :))