Diablo II - Lord of Destruction Error

I just downloaded Diablo II - Lord of Destruction and install it on my pc successfully but i can’t connect to battle.net
The error i receive is “Unable to identify Version”
The version i have is " V 1.14b"

1 Like

Hey Acolitu,

1.14b is not the most recent version. Usually when you connect to a realm it pushes the 1.14d update, however, USEast and Europe don’t seem to be doing that.

So you can try two things:

  1. Connect to Asia to get the 1.14d update. If you run into trouble with that,
  2. Manually download and install 1.14d. See this post for the details. Be sure to install the matching update for what you have installed (D2 vs LoD).

It worked with the first solution… tx

Now why did D2 and LoD work for me on my Mac weeks/months ago, and now its not updated and supported and now I can’t play?

Unfortunately, there’s been no word from Bliz besides that they are aware and are tracking the issues.

However, starting yesterday, reports are coming from players that Macs are able to connect again.

Hi, connecting to Asia worked for me to get the update, however when I try to log in to Europe, it gets stuck on the “Please Wait” screen.

When I try to log into any other region, it says my password is incorrect.

Turning firewall off does not fix issue.

Any advise?

Edit: Nevermind i just created a new Battle.net account ingame and it lets me on. Weird.

Not linked to this account though, dont suppose thats an issue?