Diablo II (2000) LOD - Game creating issue

Not sure if this game is even supported these days, but…
All of a sudden, I’m not able to create games anymore. Whenever I try to make a game, it just tries to load for a while and then it takes me back to the screen where I can either join or create games. I am able join others’ games, but this is inconvenient because then I can’t do my quests.
Can someone tell me if what’s going on?



What realm are you playing ?

Are you able to create a game on a different realm ?

Hi, Annihil8r. This is because you are on 2 something, and I belief what is right for u would be an extreme opportunitty to speak what is true to the relms of your mind and read teh Holy book of the Lord, then come back and try to play the game again. It’s really long, so I don’t think you will get through this book in one sitting. Good Luck,

I’m on US East. I also tried from different realm, Asia for example, but same issue.

1 Like

I’d say try to join my game, but I know how bad east side can turn. UR much better off playing solo and saving your account from boozenet when teh Nigerian’s convoy enters a clairvoyant state and telepathically enlacves all of northern ttEthiopia. Then save ur arrows and stakes for ‘realzombies’

1 Like

Hi again,

That’s odd…

Have you been creating many, many games… something like the numbers quoted by @TheDarkJedi here ?

If not, then… I don’t know. Perhaps someone else will come up with something that can explain a multi-realm issue like this.

I suppose you could try contacting Blizzard directly with a ticket… there aren’t many support options available to Diablo II LoD but… you could try the ticket form here: https://us.battle.net/support/en/help/contact/354/ticket . You’ll have to explain in details what the issue is but, at least, they’ll be able to look up your account and see if there’s any kind of play restrictions on it.

Good luck with this !

Yeah, I don’t think TheDarkJedi’s quote applies to me. Because this started happening last night. Few times I tried and I was able to log in…and I was able to go in and out of the same game I created just to transfer some gold and items I found to my mule. Then I logged out for over night and starting this morning, when I tried to create game to do quests to level my character, it stopped creating game.
I’ll go ahead and submit a ticket and see what they would say.

1 Like

i have same issue here, uswest realm

I’m now testing things…and I’m having trouble creating games on U.S. West Ladder.

There is a long delay, then the screen goes to the portal animation, then suddenly back to the main lobby screen.

Non-ladder is working fine all around…U.S. West.

1 Like

This is the third day of not being able to create a game on USEast (any difficulty, any character, ladder and non.) Joining an already created game is no problem. USWest non-ladder seems to be working fine comparatively.

1 Like

I just tried and I am able to create the game now. yay!!!
Hope the issue doesn’t come back…LOL

This is an issue that occurred after the offending realms were down for 15+ hours prior and it is on-going. It seems the engineers forgot to fix something correctly and as always failed to give any information as to what the situation really is.

1 Like

Well, I guess I spoke too soon. After playing for bit and logged out for couple of hours and just tried again and I’m right back to not being able to create a game. :frowning:

1 Like

In my opinion, with so many issues going on I think the simple solution to this would be to just give Diablo II to Runic Games, because I believe they would do a much better job with it considering they were the original legendary Blizzard North team that created it.

This non-sense Blizzard is doing is just going too far left field this far into the life of the game to justify any reasoning they provide.


Having the same problem; my guess is it may be related to the D4 “server slam” going on. Extremely annoying. Hopefully this will end tomorrow afternoon.

I would agree with what Kalroth said to give the servers back to the legendary Blizzard North team! This should not happen to an old game like this that cost really nothing to run on a box! Activision is a crock of **** and I wouldn’t waste my money on their games ever. The Blizzard team needs to start reading these forums instead of ghosting us all!

1 Like

Can’t disagree.
If they are going to keep the game around, the least things they can do is to keep up with the maintenance as well. But they’re too focused on new games like D2R and D4, this game has been on the shelf collecting dust.

As for the game creating issue, I was able to create game (I had to try few times and got lucky), then when I tried to switch character to go into the game I created, now I’m stuck at “Checking Versions”…sigh~~~

I am having same issue. Sometimes on 3rd or 4th try a game will actually create and no problem after that. Every time I log back in though same thing happens

1 Like

…meantime…Oh yeah!! Forums are the answer!!! Close down ways to get to their tech support!!! After all I have not bought new product that my PC cannot play anyway. Me on income support and all. Money talks right?? (sarcasm intended)

1 Like

Side notes I am using Wifi on an older desktop. A USB plug in D-Link for the wifi hardware. Have rebooted the PC have unplugged and reconnected the D-Link etc… The problem is not here. The tech issue has to be fixed by Blizzard