Diablo - Direct Draw error

Hello, I just bought Diablo 1 on Battle.net.
The game won’t start because of a Direct Draw error.
It says to look for the SETUP.EXE on the CD. This brings me back to my young days, but doesn’t help me in 2024.

What should I do to resolve the problem?

Thank you!


I am having the exact same problem, there isn’t anywhere in the support section to address Diablo 1 issues or refunds either.

1 Like

Same problem here with Hellfire.

dx. cpp line 183

BUT… i used the desktop shortcut and worked.

1 Like

Im having the exact same issue. “The error encountered while trying to initialize the video card was: Not implemented at: dx. cpp line 183”. I wanted to play it so bad to bring back the memories, but now I cant and as of now I waisted $10

so u can use the desktop and get in but have issues getting in from the battle.net app?

If you meant in-game battle.net, forget it, as it was deactivated decades ago.

?? No it wasn’t. The servers are up. They’ve been back up for years, ever since they re-introduced it on GOG.

No way??? Amazing.!!!

no, not in-game battle.net. Im talking about it wont load in the battle.net program where the other diablos are

Same problem here Direct X Draw error

1 Like

I resolved this error by setting the executable to run as admin. I also set compatibility mode for windows xp service pack 3. Not sure if that helped, but run as admin definitely helped

1 Like

Having Direct Draw Error???
The Solution is here !

Install DirectX !!!

( Note ) DirectX installer comes packaged with the game.
Also: comes packaged when you check & do windows updates.
Otherwise you can manually download it from microsofts website.

Blizzard just posted this about DirectDraw issues:

So launching from Battle.net was giving me the same issue. However I found that if you go to the games program folder on your computer and select the executable application directly then the game will launch. For me the application was Hellfire.exe in the Diablo Hellfire/Hellfire program folder.

I just want to highlight for visibility what Lionheart posted above:

Yes I saw that and tried it, I get the same message. I tried all the suggestions from everyone on here and still have the same problem.

1 Like

It isn’t working for me either.

i paid $10 and now i need to get my CD from the original release???

This did not work initially for me. I uninstalled from my HDD F: and reinstalled directly to my SSD C: and it worked by using the desktop shortcut AND bnet launcher. Unsure what it means, but worth a shot for those still having issues.

repost cuz im dumb and deleted cuz i dont post on forums

Still not working @Blizzard