Diablo 1 Multiplayer not working

After I got the game running, I was pretty hyped and ready to play on battle net.
But it doesn’t work, and just throws me for a loop.

Here goes the explanation:

  1. Multiplayer → Battle net.
  2. Then I get an "There is a new version of the software available. Battle net requires that you use the latest version. Your software will be updated now.
  3. “The update has been downloaded successfully. Your application will now restart.”
  4. Give software permission.
  5. When downloaded and executed Blizzard Updater v2.24, I get the error “this program is used to upgrade programs through battle net and does not need to be run.”
  6. Loops back to 1.
    I’ve tried running as admin, opening ports, add firewall etc. like the old days. Nothing changes, same loop.

Multiplayer → local area network(IPX) and Modem interface is broken, when u go into it’s menu. U can “wash away” the bugged screen, by moving your mouse around the screen.

Direct Cable Connection seems to work, at least solo, don’t have the possibility to check with 2nd PC or player currently.


I’m having the same issue. Still throws me into a loop.

We need a hotfix blizzard


Aight so I’m not alone.

A fix would be S+ Blizzard

Same here, its mess. Unfinished, untested product.

1 Like

If everyone requests a refund it might actually get fixed.

I wish they could fix it quickly so I can play with my friend

1 Like

Same problem, I’m also having one with the directx3. It’s only been out for hours, so I guess we can expect fixes soon.

Blizzard just posted this about a Direct Draw issue:

There is a Diablo 1 General Discussion Forum here:

1 Like

Maybe it’s better if you download the v1.09 patch from a (safe) website instead through Bnet.

same for me. made sure admin is on, tried compatibility mode for the programs. nothing works. just loops

1 Like

I just purchased and installed Diablo - Hellfire off of Battle.net. I got the DirectX error and appears to be resolved. Now… How do I play multiplayer? I do not even see it as an option. I expected this to be configured with this purchase. Any insights?

1 Like

Hellfire is single player only. Diablo Classic is multi and single

1 Like

I don’t think there’s a need to refund, I think they are working on it.
Otherwise they would be lying to their customers, since this is on the sales site:

Unite to destroy Diablo

Join forces with up to 3 other players, delve into the hellbound depths beneath Tristram, and face the Prime Evil together.

Edit: It’s just odd that there’s no word about it at all, silence.

Realized Hellfire was solo only. Getting the same loop as OP on Diablo Classic

I mean, technically it does.
Edit: Also please stick to the subject, I’m not interested in talk about private servers or knock off products.


Product Notification
Includes the Diablo: Hellfire expansion
EUR 9.99
Available actions

  • Add to Wish List
  • Localization for this game isn’t available. You can purchase the game and play it in English only.
  • Battle.net® Account required <-This bit here
  • Any applicable VAT included
  • System Requirements
  • Product Details

and further down

Product Requirements

  • Localization for this game isn’t available. You can purchase the game and play it in English only.
  • Battle.net® Account required <-This bit here
  • Any applicable VAT included

Then at the very bottom of the page

Free access to Battle.net requires access to the Internet and acceptance of the Battle.net Terms of Use Agreement.

So we can conclude that access to Battle net is a requirement, a battle net account is required, and for that purpose internet is a requirement.
We can also conclude that the game offers you “multiplayer” through “battle net”.

1 Like

Hey all,

About the silence, the TS forums (across all the games) are mainly player to player help. A Bliz TS agent might drop into threads to post, but it’s fairly rare, and also not required of them.

About the multiplayer functionality, the versions bought through Battlenet are intended to have Battlenet based multiplayer. But as it’s easy to see, there are some issues Bliz needs to work out.

  • For Diablo 1, the DirectDraw issue has a support article to try.
  • For D1 and WC2, the network ports issue also has a support article to try. (It’s the same instructions for D1 and WC2.)
  • The update loop unfortunately doesn’t have any updates yet. For now, people could try a Support Ticket for that (or for anything that the support articles above didn’t help with). It probably can’t hurt to try the network port config to see if it helps with the update loop. If not (or gets worse), it can be undone.

One thing to note is that the GoG versions of D1 and WC2 have two modes: classic and enhanced. Only the classic modes have Battlenet functionality.


Thank you very much for the update!

1 Like

I’m getting the same issues as everyone where battle net loops as per OP Piece Of Panic posted on this thread …

is there a way to find out when this will be fixed / update released because I’m super happy about the release just wish battle net was working


As an experiment, try the network config described below. If it doesn’t work (or gets worse) it can be undone. I’d like to know if it has any effect.

Close out the game completely, then make the network changes, then try it again.

1 Like

Thought of something to try, PieceOfPanic.

The GoG version of D1, which works fine, is on patch 1.09.

See if you can find a standalone installer for 1.09 online. (Just be careful where you get it.) I searched for “diablo 1 1.09 patch blizzard” and got a bunch of hits.

I noticed that there is a 1.09b as well. I’m not sure if that will work. I just suggested 1.09 since that’s what GoG’s version is running.

Try running the 1.09 installer with the came fully closed. If it finishes, try getting into Multiplayer again.