Cold War Problem Game Stuck On Loading

Whenever I launch the game it begins to kinda lag and stops the animation you get at the start of the game, then I see the terms of service and before I can click accept the game goes to this black loading screen and I can see this “compiling shaders to optimize performance during gameplay” load to 100% and then nothing but this black loading screen.

I then tried launching the game from it’s install folder as administrator and now the animation at the start of the game actually runs smooth and it looks like the game’s about to work but then I get this error saying I must launch the game from battlenet client…

I’ve now installed latest drivers for my 1080ti, cleared nvidia 3d settings profiles to defaults, scanned the game files, switched firewall off, etc. but no change, only thing that seemed to work was launch game as admin but blizz don’t allow that??

1 Like

This BS dosemt work…great beta weekend…DISAPPOINTED !

1 Like

Me and pals were gonna play it same time and only one whose doesn’t work is mine, so yeah it’s a shame but you know it’s beta and even if we don’t get to try the game out at least this problem has now been reported.

1 Like

Funny cuz my friends game also work…but my game dosent…i found out if you start the main exe file with admin rights then the intro loads normaly until an error pop up and says you must run it from battelnet launcher…also i see the game is asking me to click agree and confirm something and then it shows me to log in an activision account but after 2-5 sec then the black screen apears again…so i think the problem is that the game tryes to login battelnet but want you to login activision account or visa versa…and these 2 things creates a black screen in confusing the game

1 Like

So is anyone at blizzard going to address this?? I am unable to play the beta because of this.

2 Likes

SAME ISSUE , cant seem to find anyone addressing this . I dont have a bad rig and I tried every possible way to fix it up .

This particular forum is for issues installing Classic Blizzard games such as Diablo 2, Warcraft 2, etc. So, no, they won’t address the issue here.

You seem to need assistance with a modern game made by Activision. If you have issues launching the game using the Desktop Launcher Application, which Blizzard makes, you can post on the Desktop App Tech Support forum.

If you have issues with the Launcher recognizing a game key, you can try the steps here Free Beta Cold War

As said there,

While we can of course still help out on this forum, troubleshooting for the Battle.net desktop app is best provided through the Desktop App Tech Support forum. This classic games forum is more for our oldschool games like Diablo 2 and similar.

If you have Technical issues once CoD:CW is launched, you need to contact the game maker - Activision.

https://support.activision.com/contact-us

This is stupid…thx for the beta…NOT !

Syncing time don’t work either. Anyone find a fix yet?

The Classic Technical Support forums are for classic games such as Diablo II experiencing technical issues. Please feel free to review our welcome thread and our call of duty post here.

As this is not a classic games issue, this thread has been closed.