Cant update MW2 error code BLZBNTAGT00000870

Cant update MW2 error code BLZBNTAGT00000870. Its asking for permission to make changes which Is usually followed by an admin popup and you just click allow. But the admin popup is doing the popping upping.

11 Likes

same is happing with me its not asking for permission

4 Likes

Same is happening here as well. Have been trying since 9:30am EST. Using a Mac and never have had issues before. Seems to get to 90% and then pops that error. Nothing on the link helps either.

im dealing with same issue, not getting a pop up – any solutions?

This is happening to me as well.

Same thing here as welll ugh!

reinstalling battle.net seemed to work ugh!

I was having the same issue and I just ran Battle net as administrator and then it was able to get past that

3 Likes

This worked for me.
Seems to be an error with Battle.net, it asks permission, I approve the permission, it then gives me the error code.

Close battle.net, right click, launch as administrator, problem solved.

Thanks mate.

1 Like

Mine is having the same error too, even closing and launching as admin isn’t working

2 Likes

None of the above solutions work.

oh my goodness i love you

none of these worked for me i dont understand whats going on any other solutions

running as admin doesn’t work either.

1 Like

all i wanna know is why dose this happen

1 Like

So I did a scan and repair and after it was completed, closed the app and ran as administrator and worked for me.

it works!!! thank you

I also found something else that worked for me if anyone is still having issues.

Open your task manager and end the Battle.net Update Agent task. Click update in the Battle.net app and it’ll restart that update manager.

Hope that helps.

4 Likes

This worked for me, thanks!