Can't play Frozen Throne after Battle.Net update

I tried playing Warcraft III: The Frozen Throne today on my Windows 10 machine and the battle.net launcher updated to the new version (1.32.0.14481) When I try clicking play for Warcraft III I get a screen saying: ERROR THERE WAS AN ERROR IN HANDLING THE REQUEST.

The only option I have is to exit game which takes me back to the launcher. Will I be able to play The Frozen Throne online or is that no longer supported? Also will I need to purchase Warcraft III: Reforged in order to play The Frozen Throne?

9 Likes

I have the exact same issue. Normally I only played offline for frozen throne. Now after the latest update and logging onto battle.net for a hundred times, I can only launch reforged and see the error message saying it cannot handle the request when logging on battle .net for the 101st time inside reforged. Where is frozen throne??

I also have the same damn issue. Well done blizzard! So not only have I not been able to play Blackout for over a year, now I cant play TFT either! Get your shi*t together, I am not wasting any more money on games from you, you seem to forget the people in Australia like to game just as much as the rest of the world.

I have the same problem. As soon as Warcraft Reforged launches I get an error that says “Error, there was an error handing the request.” I have tried reinstalling the game to little success. It did let me enter my email and password at one point and sent me a validation email but once the code was entered I got the same error. Now on day 3 of this game not working. I did not purchase Reforged because I owned the original and wanted to try it out before purchasing. So far this experience has been underwhelming to say the least.

Computer: Hp Elitebook 8560p with 32GB Ram and Core i7 Processor.

I posted this a week ago and still no answer from blizzard. I just want to know if I only have my original Warcraft III Reign of Chaos and Frozen Throne CD’s, will I still be able to get on battle.net and play TFT online like before or will I have to purchase Warcraft 3 Reforged?

Hey romdawg,

The error “There was an error in handling the request” usually means that either you don’t have a Warcraft 3 CD key attached to your Battle.net account or that you haven’t purchased Reforged.

You are still able to play on Battle.net and play the ROC and TFT campaigns as long as you have an ROC CD key registered to your Battle.net account. A Reforged purchase is not required to play the Classic version of the game.

If you still have your CD keys, go ahead and register them to your Battle.net by adding the codes here:

https://account.blizzard.com/overview

All download links lead to Reforged. Nothing but Reforged exists in the steam-clone. There is no way to download anything but REforged.

whoever was in charge of this dumpster fire reforged launch should be fired! why mess up the classic games or merge them into this nightmare battle.net launcher, leave them alone!

just bring back the stand-alone classic games, simple solution!

1 Like