Can't patch diablo 2 for battle.net

When I try to get on battle.net it says “battle net is unable to properly identify your application version diablo 2”, however if I go into the game files it shows up as having 1.14d in the patch history… but when I run the game it says 1.14b???

HELP!!!

Go down to where it says “If you experience any issues using the links above, you can directly download the most recent patches” and download the appropriate 1.14D patch.

I’m an old fart that used to love D2 back in the day. Came back to practice for the Resurrection release. Is it just D2 (and the way they went about it) or is Blizzard the anti-Christ and just absolutely useless? The above ‘help’ about updating is to show a download for the original game… of course we’ve tried that… being stuck on 1.14b is NOT solved by… downloading 1.14b. I’m stuck on 1.14b as well and regret ever coming back to Blizzard.

Finally fixed my updating issue… went to the Asia server… worked first try.

THANK YOU ZONKER, i was literally tearing my hair out trying to patch this damn game, of course the asia server would work face palms, what was i thinking thinking the american servers would work, lol

Hey folks,

There’s an issue with the USEast and Europe realms where if someone attempts to connect with 1.14B, the server won’t push the 1.14D update.

There are two workarounds:

  • The first has been mentioned above: connect to Asia to get the update. If you are able to connect to USWest, that will work too, however, USWest has a different issue that might prevent connecing altogether.

  • The second is to manually download and patch up to 1.14D. For this to work, the proper 1.14D update must be used. If only D2 is installed, the D2 update must be used. If LoD is installed, the LoD update must be used.

I was able to download the 1.14d through thee ASIA Server just now like Zonker mentioned… however I am still unable to connect to East Servers… or any server for that matter… Ive never had this issue before up until today…

Are you on a Mac by chance?

Try connecting to diff server or realm, that should proc update. Then your good to go

I just want to second that Changing real to Asia updates version to 1.14d. That seem to be the only way to update it. Then change back to whatever realm you play.

If connecting to the Asia realm doesn’t work for anybody (it doesn’t for me, for example) the game can be manually patched (the patches are at the bottom of the article.

Be sure to use the patch that matches your intallation:
D2 (2000) installed → D2 (2000) patch only
LoD installed → LoD patch only

I’m on a mac, I tried the new 1.14d LOD patch links, but the installer won’t open! I’ve also tried going through the asia gate but as soon as it starts installing the patch the game crashes. I’m still running macOS mojave 10.14.6 !

I’m getting an error trying to manually install 1.14d that says the version I have is more recent.
FIX please!
I’m on PC with all current Win10 updates and drivers.

Hey Merriwx,

That usually means you’re using the wrong patch.

In my post above:

The support article that contains the patches has them separated out by installation type.