Cant Install Battle Net Error BLZBNTBTS00000028

I downloaded the latest battle net desktop app. Was unable to even install as it will show the error code BLZBNTBTS00000028 and state:

We can’t connect you to the Blizzard patch service. Please check your internet connection and try again.

Have done the necessary troubleshooting such as disabling firewall/AV, reinstalling all drivers such as GPU and even my LAN driver (using wired connection). This is a fresh install from formatting my SSD so it’s weird that I cannot even launch the program. Other platforms such as S**am can work, and other internet functionality are ok.


I have the exact same issue and have done all the same troubleshooting. The issue is isolated to

Having the same exact issue. Don’t know whats going on

Same here, tried every single recommendation in the above error code’s page, still could not get the setup file to run/ instatt the launcher.

Same here BLZBNTBTS00000028.

Same here, pls advise

Same here as well. Can’t install launcher after clean installing Windows.

same here, formatted windows, clean install, i even reset my router to default settings.

all that trouble and time spent reconnecting all my devices, still no go.

seems like no help at all from anyone, even on reddit. oh well, nothing of value was lost anyway.

me too. fresh windows 11 install on the same computer i was blitzing through diablo 3 and 4 just the previous day. decided to format my computer which i do every 6 months. lo and behold i suddenly cant get past the error message with the error code BLZBNTBTS00000028. Im living in Singapore using M1 as my ISP if that helps.

you can fix this issue by enabling UDP on your home’s firewall. You can also enable open NAT port forwarding if your firewall has that feature.

Alternatively you can manually input the required TCP/UDP ports for the blizzard application. Now turn off/restart your computer. Unplug or disconnect the ethernet/wifi on the computer. Wait a minute.

Retry the update or reinstall the blizzard app and try the update again. It should work now. That fixed my issue.

Link to manually input ports. https:// us forums.blizzard com/en/sc2/t/how-to-put-in-ports-number-for-blizzard-games/7533)



Please don’t mangle URLs… especially with spaces !

If the forum software complains that you can’t post a link, convert your link to preformatted text by:

  • highlighting the entire link,
  • clicking on the </> button on the formatting bar at the top of the composition window (button #6).

It will look like this: . While the readers of your post cannot click the link to view the article, they can copy it and paste it in their browser.

In any case, here’s a clickable link:

Best of luck in your games !

i regularly port forward/trigger games and have added all the ports from that link and all the different troubleshooting steps in the blizzard support articles but nothing works. I was just playing Diablo 4 the night before on the same machine. Decided to do a fresh Windows 11 install and this happens. Did a tracer route:

Tracing route to []
over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms
2 3 ms 3 ms 3 ms []
3 2 ms 3 ms 2 ms []
4 7 ms 2 ms 2 ms []
5 3 ms 3 ms 3 ms []
6 3 ms 3 ms 3 ms []
7 164 ms 164 ms 164 ms []
8 165 ms 164 ms 191 ms []
9 635 ms 659 ms 439 ms []
10 * * * Request timed out.
11 221 ms 221 ms 221 ms []
12 222 ms 222 ms 221 ms []
13 221 ms 221 ms 220 ms
14 221 ms 221 ms 221 ms

Have did this about 5 times and there’s always a timeout at the same place

1 Like

same here, still no go.

Same here. I built a new windows 11 rig and battle net hits me with error code BLZBNTBTS00000028 when I try to install it. Same M1 user as well.

Good morning,
I had the same problem as you with the CODE: BLZBNTBTS00000028.
Problems solved for my departure I explain:
Right click on the file and press "Run in tans as administrator and the installation should run this.
Hoping to solve the problem for everyone …
Good luck

Same here… also using M1 in Singapore… also recently format PC and tried to install it but nothing works… this is very annoying. I did the same trace route same results.

I got the same error BLZBNTBTS00000028 when I tried to install battle net on my girlfriends PC last week, I also tried to run it as an administrator, but it didn’t help. She had battle net before, btu then she deleted it, so she had some saved data, only after deleting it all I managed to install it.

Oh yes, M1 user here! I still have friends on discord/streaming OW2 so it definitely isn’t a game problem per se!

1 Like

Same problem, around 2 months back I could install battlenet without issues. Using the exact same computer and setup right now gives me the BLZBNTBTS00000028 error…

Exact same issue as everyone above, let me install the god forsaken program and play the games i paid stupid money for!! Absolute joke after buying Call of Duty for 80 poxy euro and now i cant even install the bleeding program, even when i had it installed, the game would never launch and scan and repair just looped at 3%. Absolute piss take company.

1 Like