Can't even submit a ticket?!?

This is getting ridiculous to a whole new level… It’s been 2 days that I can’t play because of “You were disconnected from Please reconnect” or whatever that implies.

I’ve been trying to file a ticket for the past two days and it literally doesn’t work. Whenever I fill the information and click submit, I’m brought up on a page that tells me to do other things before, with another “Submit” button at the bottom. Clicking that button does nothing for 10 seconds, then just brings me back to the form page (where I enter tracert.txt, err msg, etc). If I click submit again, back on the “before submitting a ticket, try the following”. This goes on in an endless loop and there seems to be nothing I can do to successfully submit my ticket.

I’ve been trying this endlessly and never get to the point where my ticket is successfully submitted. I go in my tickets and both active and archived are empty despite me repeatedly having tried to submit a ticket.

I tried on Chrome, Chrome incongito and now edge. Same behaviour on all 3. Clearing cookies doesn’t help. I don’t even know what to do, I can’t play nor even fill a ticket…

1 Like

Feel so sorry for you :joy:

similar problem here. it just keeps telling me an error occurred and to try again.

lol dec 2019 and still no reply you need to call them scammers then they will respond :stuck_out_tongue:

Seriously. I’m having the exact same issue. No one is getting any responses, so I tried my hand at submitting ticket. Also going through all the stupid hoops to meet their demands in order to submit a ticket, and at the end, bam. Nope. “You can’t submit this ticket.” < Actual text. Can we get a response please? Why are you guys even bothering to monitor the bots so hard, but ignoring actual players??

I don’t know if this is a valid solution, but I selected diablo 3 to create a ticket a few times I couldn’t find diablo 2. I just wrote in the text that it was a diablo two problem then explained issue. Hope this helps.

Only way to get a response is to go into your main account page and submit ticket from there. Otherwise you might as well as not exist. I am not saying they will help(they were not able to solve my instalation/update problem), but at least they responded into sending me into us.forums where all the ‘classic support’ is supposed to be. Only to see all the topic created…never to be responded by anyone but other than players. Welcome to new Blizzard. Where they care only fore chinese money. Not their playerbase. :wink:

And now it says is not responding. GG, Blizzard. Many thanks. A1 steaksauce, here.

To resolve these issues I submitted a text file with the details of the ticket as the attachment