Can't even launch D2 ressurrected

I know there’s been a bunch of issues with failing to join/dropping/unable to log in, etc. I can’t even get past the play button. Once I hit it I get a popup that reads “the application encountered an unexpected error” and Bliz is polite enough to ask for my feedback. Anyone else getting this error?


I have exact same issue. I have two laptop with almost identical hardware spec.

One laptop can go all the way to right before start playing with a character. I said right before because the game crashed during the map loading stage.

The other laptop has the “the application encountered an unexpected error” issue.


i dont even get an error, i hit play, it says launching then playing now (quickly too) then it simply says play again. restarted comp and still, i cant actually get it to launch :frowning:


I am having this issue minus the error message. I press play it says launching then playing now, then back to a blue play button. nothing happens.


Mine is doing the same even with the Beta, I don’t know what is happening…

1 Like

This is what I have encountered.

Press “play”.
“Play” turned into “Launching”, then “Play Now”.
Screen go dark for a second or two.
Dark screen disappeared. Screen back to normal.
Error message pops up.

I have scan and repair twice. Uninstalled reinstalled once. Still not able to start.


Same!! I have reinstalled and repaired I don’t know how many times now, refund much? :confused:


this is the exact message ive been getting since i first tried to log on at around 1130 im searching for issues ill keep you posted. let me know if you find anything out


same here my system connection and everything is great i cant seem to get passed play not surprised blizzard releasing a game with issues ima give few days then get a refund.


Same exact problem here. I sent off a full report to blizzard hoping for a response.

1 Like

keep us posted thanks man

1 Like

Same here Nathan I can’t contact blizzard

1 Like

Same. Also scanned for errors and reinstalled, to no avail.


**play, play, play and play but no play d2r **

Trying to play sine 10am, NINE hours. Don’t get us to pay for a product we can’t use. I get

Uninstalled, reinstalled, repaired, same.

Why pay upfront for a product that basically is not accessible. Putting in for a refund.


Same here.

Reinstalled, disabled anti-virus, checked specs, and still nothing.

Click Play > Says it’s Playing > back to “Play”


I get the same issue.


Yeah clearly an on going problem at this point. I’m having the same problems with launching. Asked around my friends who have been able to connect and everyone is talking about issues with server drops but that’s to be expected on first day. I get it, servers are overloaded right now. However I’m not even getting the chance to try and contact the server before the launch fails.

1 Like

just read on d2r forum that they have been working on a patch for this issue. could be out in the next few hours. im trying to find link to post here. seems like it describes the problem we are all having

Same here, i have run as administrator, download it 3 times, scanned for problem on bnet platform and checked for my firewall… can’t get pass the ‘‘unexpected error’’