Cant download app fully windows 10

I have tried to download the battlenet app multiple times . went threw all the checklist items and reinstalled windows. still gets stuck at 45 or 56 percent . its only 4.7 mb. Why wont it download.

8 Likes

Hey DeadlyAffect,

It sounds like there may be something happening with the network. Can you try testing a mobile hotspot or free VPN to see if it’s able to finish downloading?

Having the same problem - downloads to 1.4mb and then falls over

I am having same issue Just installed new OS and can not finish DL battlenet I have DL and installed Origin Steam ect… Is blizzard having issues

ok , I also had the same issue, half way through the download of the game, and also the battlenet app it was just stopping. I tried everything, removing firewalls, different browsers, nothing was working …so I got advice from a guild member and have a solution! He said the blizzard site regarding this has been broken for a few weeks now and for some reason they have not been able to fix it, so he searched for an alternative download location. and IT WORKED! so I will share it here. Well… it’s located at http semicolon forward slash (x2) dist dot blizzard dot com forwardslash downloads forwardslash bna-installers. They wont let me include the link here. You can also google alternative down load sites. GOOD LUCK

1 Like

Its happening with me too, same issue since last few days, cant even download battlenet app.

Me pasa lo mismo, pude descargar battlenet app pero cuando pongo a descargar Call of duty Modern warfare, se me traba en 1.10mb/s

It’s on your end dummies, comin at ya from east coast iglooville.

Are u bot? hhhhhhhhhh

I’m having the same issue. Restarting and different browsers don’t help. Have no clue what the issue is.

I was having the same issue. For me this was fixed by going to https://us.battle.net/account/download%20/ and downloading from there.

1 Like

Hey, not sure if it’ll work for you guys but i right-clicked on download link and hit “open in new incognito tab” and it seemed to open and download there so maybe try that… hopefully it works for you too :slight_smile:

Yeah, I guess this was meant to be as I haven’t been on for over a year. I tried DLing the app several times and this isn’t working. I see there’s no support nor response.

1 Like

This fixed my issue instantly downloaded the app

Alternate download location working from ‘Major Geeks’. This is the exact same problem you get if you try to download from a Linux Distro.

Still cannot Update or install battle.net this is frustrating.

I am pretty sure it has something to do with Windows 10 Version 1909. I just replaced my SSD and have not had any luck getting this to DL. I am able to DL the app on version 1809 of Windows 10.

https://us.battle.net/account/download%20/

This link also failed to DL for me.

Hey all, please try the steps in this thread.