Cannot log into app Android

Every time I try to log into the mobile app it just keeps me in an endless loop of entering my password. I have uninstalled, reinstalled, cleared cache and data, restarted the phone, and still the problem persists.


Same, its a total pain, specially with the Authenticator app spamming that its being replaced by the Battlenet app that can’t be logged into.

Hey Roz,

If you mean the App cache/data, I would also recommend clearing the chrome browser cache/cookies.

If you’re at the Login screen:

  1. Tap on the hamburger (aka 3 vertical dots) button in the top corner
  2. Tap the Info icon (i in a circle)
  3. Tap the “Cookies and Site data” option
  4. Tap the Trash Can icon to clear the cookies

We’ve seen a number of reviews about this on the Google Play store and our team is investigating but wanted to suggest this as a troubleshooting method while they dig into these reports.

Addition info that would help includes:

  • Device model (Google Pixel, Samsung Galaxy…)
  • Android Version
  • Default browser being used (if not Chrome)
1 Like

I’m getting a version of this problem, but not exactly as described in the OP. I have tried rebooting device, clearing app caches, reinstalling the app, disabling adblockers, etc.

Got the “this app is migrating” message yesterday from the old authenticator app. My app now gets stuck on “still connecting” screen when app is launched, and does not progress past this screen. Luckily, I did not lose access to my account’s 2FA prompts since I did not (yet) uninstall the old authenticator app.

Device model: Google Pixel 3
Android Version: 12
Authenticator app version: app version:
Default browser used on device is Firefox

So I’m encountering the issue too, yay!

Latest version, and I know it is because I only just downloaded it, and I can’t login. The app directs me to login on the website, and I was able to login the first time, only for nothing to happen. Close the website, hit the button again thinking it’ll just instantly go in, only for it to ask me to login again. I login again on the website, only to be stuck. It won’t login anymore. I can force it to login by navigating to the login page manually, it logs me in fine because I’m already logged in but it won’t login on the app. Try to login on the page the app directs me to, nnope! Even if I logout then try logging in, nnnope! Won’t let me login.

I’ve seen some reviews on the GPlay page that say google chrome works, but I’m not going to change my phone’s settings to accomodate a single app, I’d rather just forever use the old authenticator app.

Can’t login, refuses to load login page after first attempt.
App is up-to-date.
Android phone is up-to-date as of yesterday. Galaxy z flip 3, version 13
Default browser is Opera GX.

There is something wrong in the opera GX settings and I cannot seem to figure out what it is, that blocks the login process.

I tried setting open links in apps, but it didn’t change anything.
But when I try using different browser, the login it works perfectly fine and it takes me to the app without any issues whatsoever.

The issue is Firefox, but you don’t have to change your default browser permanently.

I did this Samsung phone, July 2023:

  1. Settings > Apps > Firefox
  2. Find ‘Browser app’ (it’s set to Firefox), change it to Chrome
  3. Start app and log in (should work now)
  4. Go back into Settings and change Browser app back from Chrome to Firefox

I’m still getting this very same issue and tried all the above and still no joy. So bumping this post (as suggested in another thread). Hope this gets resolved soon!

1 Like

I also have this issue and nothing seems to help.
What I noticed is that I also get the login loop when opening the page in the browser (on FF and Chrome/there is an option in the app).
In the browser (mobile and desktop) I started removing parameters from the URL and then logging in.
Removing “&ref=blizzard-social%3A%2F%2Flocalhost%3A0%2F” for example eliminates the redirect loop but leads to a website not available error.
Removing the parameter (with or without the parameters after that removed) “&app=xyz” lets me login just fine, so the issue might be with the app parameter in the URL the app tries to open?

1 Like

@kalviery look at ticket id: 90135520
help for a possible solution there. its a MS edge thingy, not a end user or fail

Changing the default browser app back to Chrome fixed it for me. I was using Opera GX as my default browser though, so it’s not just FF.

Thank you! My default browser was Brave, changed back to Chrome and it worked right away!

1 Like


I also try to get the App working and all the above mentioned things do not work for me.
What is the most strange in my opinion is, that I face the issue on iPad and Samsung Smartphone at the same time.
A friend of mine just told me, that while I try to log in with the App, he gets 5 times the information, that I logged of. So communication with the server basically works…

Changing the language or the default browser (I switched to english and my default browser is Chrome, clear cache, reinstall, whatever) will not fix it for everybody.

1 Like

This worked for me. Thank you much <3

I am currently unable to log into the app no matter what I do on Android. I literally only use Chrome so that’s not the issue. It gets stuck on “Still connecting” and then errors out and says “Oops something went wrong”. What is going on here? Why cant we just use the Authenticator???

Possible root cause…or abit closer to it at least. (if you don’t include the individual behind it).

The same problem with auth. Clearing cache, reinstalling app, different browsers, rebooting - all this didn’t help. After the first authorization attempt, a redirect occurs and the authorization window opens again, after which there is an endless loading


similar problem here. I open the mobile app, reading the three adives. Hit the log-in Buuton: nothing happens. You can see the “animation” for hitting the button, but nothing happens at all.

App Verison: - Google Pixel 6. Very recent Android Version.

This is what happens on mine also. I had already deleted the Authenticator app, but I had to reinstall it to post here… This is frustrating, twice this week I have been knock offline and had to re-enter my login info. I thought maybe I was being hacked, but nothing is gone from my accounts. If the Authenticator is going away, maybe this should be fixed first!

I have also done everything suggested and Chrome is yhe only browser on my phone.