Cannot install battle net or any game in chinese

When install battle net or any game in chinese it downloads patch from cn.patch.blizzard.*** which is not responding any more and the installation is stucked in downloading forever. Also the language selection is cached so i cannot reinstall it with another language, it will automatically jump back to downloading step. Is there a way to clear the installation cache and let me install it in English at least? (your devs are so lazy to have that bug


Are you IN China?
If so, all Blizzard servers in China shut down. License agreement expired.

1 Like

No I’m in the US. The problem here is that when I choose to install app in Chinese, it downloads data from the chinese server which as you said is shut down so it never complete. And I find no way to change the install language because it is cached and everytime I open the installer it automatically goes to the downloading step and tries to download from that dead chinese server. Which of course will stuck forever

1 Like

I am in US, I played in China (now its down)
had the same issue, but I have solved the problem.
please read this

Thanks for the information

Thanks I tried it but its not working, i only have one folder under PROGRAMDATA, no blizzard or battle net folder under other places

I am facing the same issue. Can anyone help with this problem? Since you broke up with NetEase, this doesn’t mean you want to lose all Chinese users, right? Even if they are outside China?

I have the same issue with my new MacBook Pro. Stuck on ‘Updating Agent’. It’s weird.

I’m able to resolve this with following steps.

  1. Make sure Agent and Update agent are not running
  2. Clear that folder under PROGRAMDATA
  3. Run installer with locale like this .\ --locale=enUS (in a terminal or use shortcut)

Now you should see the installer in English.

1 Like

Hey, I had the same issue. After selecting simplified Chinese, it just hang there, cannot finish the install for bnet or any games. But managed to solved the problem by editing the DNS hosts file on MacBook. You basically manually pointing the IP address of cn. patch. battlenet. co m.c n (remove the spaces) that’s cn server been shut down to (KR server I think) which is operating.

In finder, delete all or Agent related file or folder, and quit any running agent or progress in activities monitor.
find path /etc/hosts, copy the hosts file to your desktop and make another copy of it somewhere else just in case. The edit the hosts file on the desktop insert cn. patch. battlenet. co m.c n (delete the spaces) to the last line and save the file, copy the hosts file on desktop to /etc/hosts to replace the original file.
Run the install again. Once successfully installed then revert the changes of the hosts file.
I referred to some helpful links, but forum didn’t let me post here, you can search the keywords using
战网安装卡在更新服务 macbook
战网安装卡在更新服务 mac

Let me know if that helps you, I hope it does.

1 Like

Thanks! I bought a new MacBook Pro and try to install while choosing simplified Chinese and the installation stuck. Trying to install it using your method.

Nice, hope it works out for you too bro!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.