Cannot download any games from

This has been a bit frustrating for me. I haven’t been active on my account for roughly 3 years and was interested in getting back into a couple games I played previously. I’m currently on a computer running Windows 10. I downloaded the client and when I try to install a game, it will sometimes take a while to get the download ready. Then when it is ready and I click to install, I get the spinning logo for hours. I would go to bed and leave to try and install a game throughout the night and no progress would of been made.

I’ve looked into other options suggested on the forums but it hasn’t changed anything. I then decide to fire up my old computer running on Windows 7. I let client update there which doesn’t take any time at all and then try to install the game there and I get the same result. No progress, spinning logo after I click install.

I don’t understand what the problem could possibly be. It couldn’t be a poor internet connection because I’m currently have 835 mbps down and 35 mbps up, the computer also runs Steam and the Epic Game Store without any problems and I’m able to download games from there easily. It doesn’t make any sense.


I’m having similar issues, I’m glad its not just me. Its got to be on their end because I have spent all last night and this morning trying to troubleshoot and nothing has worked

1 Like

I got the sameproblem

I’ve been having a similar problem trying to update D2R for about the past 90 minutes. The logs are showing that the patch server is down, but I can ping it; also shows down here: . I also have a decent internet connection (500/15) that’s never been a problem.

1 Like

Same here. Update was stuck at ~0% and would not proceed to allow me into a game. I left it for a while to go and make dinner. Still no progress. Attempted to reinstall from scratch, and installing the app is stuck at 0%. No steps forward, two steps back. It’s frustrating.

1 Like

Currently having a very similar issue on Linux. It’s occasionally ticked up a few % at a time. Currently waiting for it to reach 100% within the next few hours to see if I will be able to successfully launch the game.

To be fair, though, I only got this far after a VARIETY of different attempted fixes.

For clarity, the updater will say “waiting for another update” for a long time before suddenly downloading a bit at random intervals.


Also having a similar issue on Linux. Spent most of the day trying to find a fix.


Same issue here. Using Linux with Lutris. Infinite update loop and won’t let me reinstall. I know there is no official support for Linux but it would be nice if played more nicely with wine :frowning:

1 Like

Going to add my voice to the chorus of Linux users having the same issue.

Could this possibly be an extension of the “launching takes 2 to 5 tries before it stops freezing through the launch process” issue?

Because this (on going for several months) issue got worse for me today just before I decided to try to update.


Same “waiting for another update” issue on linux where it updates a few percent, then stops. I got it to 100% one time and it started over. Tried everything in the book. Its not the os. I cant update on an old Debian install or my current Manjaro. Lots of room on the hard drive, and my 25mbs connection is rock solid.

1 Like

Somewhy was feeling to do a bit for you.
searched web for “battle net game not downloading”
first link being from “appuls” seems to suggest good stuff,

  • disabling temporarily 3rd party security service. some might be configured too severely.
  • and a required service to be running, as a gamer i did once deactivate services that i tought i didnt need wanting more fps :slight_smile:
1 Like

Too add some more detail:
No install method I attempted was ultimately successful. Both Lutris and Bottles would generally freeze @50% through Updating Update Agent, and if I waiting long enough I would receive a blzbntbts0000005c error code. There were a few attempts where I received error code blzbntagt000008fc instead.
A few attempts managed to make it past the update agent, but would hang at 0% installed.

What finally led to some success was copying working installs for battlenet and WoW from a PC. ran and properly discovered the WoW install, but then got stuck discovering/performing updates (the same symptoms that let me down this rabbit hole this morning.)

I was finally able to get some game time in by launching WoW.exe directly, bypassing altogether.

Hopefully these details can assist in a speedy resolution, I wanted to spend my day off in Azeroth not tinkering!

1 Like

you might have all this problem:

fix it, and it will work:

4 – The fourth Blizzard Agent went sleep fix we have for you involves clearing the cache. Here is how to do so:

Exit the Blizzard launcher.
Launch the Task Manager, confirm if both the launcher and Agent are ended. If they haven’t been, do so.
Click Windows + R to open the “Run” window.
Input “%programdata% into the open window
Click “OK”
Search for Blizzard Entertainment and folders in the Program Data folder that will come up, then delete them
Exit the window and restart the launcher
You should know that when you restart the launcher, it might not detect your games. If this occurs, don’t panic. Simply click on the “Locate the game,” which you will find this beside the “Install game” button. Then, navigate to the previously downloaded game folder. Once this is done, you can expect everything to go back to normal.

Similar issue. All games are waiting on another update. in settings ‘beta’ section shows it is updating and is stuck at 62%, relaunching and rebooting doesn’t help.

Somewhat similar issue here, for me even though my download speed is pretty darn good trying to update warzone the download speed is stuck at 100-200 kb/s. I’ve also tried every fix from both support articles and youtube and absolutely nothing helps. Pathetic

This is not relevant to the post.

Whats strange is I was able to install D3, hadn’t played it in a few years and uninstalled it some time ago, and it plays. But I cant update Hearthstone

doesn’t work for me. i even tried a fresh wine prefix (it’s like a completely fresh Windows Installation) on my steam deck.

Same issue here, the button turns into the waiting animation and stays that way forever.

So here’s where we are after a day. I’ve tried restarting my modem and clearing the and blizzard cache and unfortunately nothing has changed. I’m still at the swirling logo after I click the “Start Install”. There are a few times after I leave it alone for many hours that the logo disappears from the button but nothing else happens.

So this eliminates a lot of what it can’t be for my end because (let’s recap):

  1. I’m having this exact same problem on 2 different computers, each running a different windows operating system (WIN 10 & WIN 7) and each with their own different 3rd party antivirus.
  2. It cannot be the antivirus because I was able to easily download on the WIN 10 computer and update on the WIN 7 computer.
  3. It cannot be my internet speed because it is very fast and I’ve turned off the limiting download setting in the client.

I’m not sure what else I can do here.