Can not install batlle net

after having large issues with war craft not updating and getting stuck on “initializing” i have followed all the advise from the Blizzard support pages and finally “uninstalled” Battle net and then downloaded the Battle net d/l. now i am stuck with Battle net not installing. I have tried to install as Administrator and it still fails. it starts then stops at 45% and errors. – Whoops! Looks like something broke. We’ll try to fix it, so please try again later.

Error Code : BLZBNTAGT000008FC

please help or i may as well cancel my subscription for a game i can no longer play.

2 Likes

Same thing with me. Only it’s not stuck at 45% but 99%. It’s so frustrating.

Me too, the installation is always stuck at 45%.I think it`s a new bug.

Have you solve the problem?

no solution as yet. tried cleaning PC and removing all games and Battle net. copied files over from a good working PC and even though the games are updated files the battle net will still not work.

  • battle net still trying to update even though they don’t need updating and so still cant play.
  • still stuck on initialising
  • does Desktop app Tech support actually read and respond to these ?

Disappointed Vellyspice.

Same situation intially, though when I’m installing from battlenet-setup.ext I get to roughly 84% then that drops to aboug 63%, then pings continually between those numbers, like it is resetting the install every time. This has continued overnight the initial time. I’ve followed ever suggestion for even tangentially related issues. Hoping for some help.

Just sharing, I was able to identify the issue and get everything moving again. Identified potential Win 11 issue when attempting to start a ticket, I was unable to get system information. Seemed a missing Windows Management file was the isssue. Went to setting → recovery → selected the option to reinstall current version of WIN 11. Still kept firewall turned off during attempt at install and cleared out all Blizzard and Battlenet files before successful install, but I suspect the WIN repair was the thing.

Good Luck

Hello! Same issue here: “Whoops! Looks like something broke. We’ll try to fix it, please try again later. More help: BLZBNTAGT000008FC”. I am on Win 10, can anyone please help?

Hiya, had the same problem and reseting the WMI repository helped!

2 Likes

Can confirm! I tried every other solution, like %APPDATA% and other folders cleaning, removing firewalls, and nothing but WMI seemed to help! Cant tell if it was a mix of those things or was it only WMI repository needing reset but it totally helped. Thank you! Shame blizzard wasn’t as quick with responses tho lol