Bnet installing stuck at 45%

Got a new PC, tried to install Bnet, and stuck at 45% when installing.
Tried all other methods listed in other threads but did not solve the issue.

1 Like

+1, stuck at 45% for both PC and mac

Hi, I am stuck too at 45%!

Me too! My PC and Mac have the same problem, they both stuck at 45%! I tried many ways on the Internet on my PC but still failed but later I don’t know how I download Hearthstone and Bnet successfully. But my Mac can’t download any of them while I tried thousands of ways on the Internet. I even couldn’t find those files they said on the forums.

Howdy y’all,

These issues can happen for a few different reasons but I’d suggest starting with these steps. You may also want to check the host file for any changes, which could block the patch.

If you selected a different language during the install, these steps could also help.

45%…the same problem

1 Like

I had the same issue. It turned out to be the Windows firewall and Malwarebytes. I fixed it by disabling it.

found one solution. I dragged the whole already installed Battle folder from my other PC and it works…

Ughh, this is the most frustrating thing ever. I’ve been playing from DAY 1 on this game and this is making we want to quit. A year ago this happened and I just figured, time for a new computer. Now I’m going through the same thing. NONE of your threads or suggestions work. I see the same thing is happening to PC users, so it’s not just a MAC issue. This should not be that hard and coming from a Billion dollar corporation. Please provide a better way forward for fixing these errors. Countless hours trying to fix and weeks, if not months of total time I’ve been unable to play.

1 Like

I am using a MacBook. Get Stuck at 45%

1 Like

same 45% same stuck at 45%

Same was stuck at 45%. Macbook Pro. Have to force quit the Battle Net set up everytime.

Another one, stuck at 45% :frowning:


With a previous install of Starcraft II on another PC upgrade fail with this cryptic message:

More help BLZBNTAGT0000138A

With a link (BLZBNTAGT0000138A) to an unknown page…
Impossible to update and play game or reinstall all.

I tried the go to agent folder and find the product fine. But on my mac, it’s a db file with passcode and I can’t access and change my region. Wonder if you guys have a solution to this.

same problem.
I think blz will end. all kinds of problem.

1 Like

new computer stuck at 45% at battle net agent update

Still nothing? bring back bliz north pls.

Now i’m in, i’m verry laggy and i cant enter in anny game with us players in it. Fantastic

same!!!!!!!!macbook air(m2) anyone help?