Bnet error when trying to open

Worked only for 1 opening of the application. After closing it crashes on next launching.

I am also having the same issue, wonder if this is an issue for massive users?

This is why I didn’t just reinstall since I knew the issue was with the most recent update so reinstalling wasn’t going to help when it would reupdate, maybe try what worked for me much easier than reinstalling can be used as a temporary fix until it gets fixed properly.

Clicked on shortcut on my desktop today, then it said it could not find the launcher executable… I clicked the browse and selected from folder it popped up for me, then it opened. After I closed it and tried to re-open, and now i get a required DLL not found error, doesn’t say what dll and launcher is broken…

Reinstalling app, downloaded a fresh one and it appears to be stuck at ~95% “Updating” for 5 minutes now…

I just discovered this same error today at 4pm cst. I had no issues playing last night. Need a fix asap.

I have gone ahead and deleted the 13747 folder per other people and it let me in the game. I can at least play for now. Hopefully Blizzard addresses this issue soon.

Same issue today.
I had no issues too until now.

It’s clearly a problem on BattleNet client’s side.

PLease fix this

I get “Required Application data not found” on launch.

I renamed the 137 folder and it loads fine.

Just tried these steps and everything is working fine for me. Thanks Csmug!

Maybe you could, as a representative of Blizzard technical support, actually support the customers in the tech support forum and reach out to the QA/dev teams yourself. The problem has already been reported to Blizzard… in the tech support forum… which any reasonable customer would see as being the correct/appropriate place to report such an issue. And many customers, including myself, are having the same issue. It’s already disappointing enough that a customer had to point out that a simple folder deletion could fix the problem instead of a complete uninstall/reinstall, which is a pretty drastic and time-consuming step. Just lazy tech support instead of offering any real search into an appropriate solution - the least that could be done is forwarding the issue instead of asking the customer to post the same issue twice.


I’m surprised how there’s so little mention surrounding this. I was scratching my head last night trying to figure out why the official channels such as BlizzardCS twitter had nothing to say about this rogue update.

Right now, over 12 hours since I first encountered the issue, the only fix for me is deleting the 13747 folder every time I want to open the BNet app. The installer/updater is not working and gets stuck on 95%.

Quite frankly I’m appalled at how Blizzard are radio silent on this; really good timing as my WoW gametime has just expired, and I’m definitely in no rush to resubscribe now.


same issue here, been 2 days, i tried everything, nothing seems to work, at first it said no data found when launching, but now it just says “BLZBNTAGT000008FC”

funny how i paid to play games but the launcher is stopping me from playing said games, locking me out of my own games…

starting yesterday
when i try to open i get

A required DLL could not be found. Please download and reinstall

i found this article

i completed #1 and #2

i cannot complete #3
im on windows7
when i run

DISM.exe /Online /Cleanup-image /Restorehealth

i get

Error: 87
The restorehealth option is not recognised in this context

i do not know what to do next

i tried #4. i uninstalled
i try to download

i click “download”
and either:
i] my browser hangs, then after a minute get

504 Gateway Time-out

or ii] i get

This site can’t be reached
The connection was reset.

are the servers for downloading down or just me?

i made a ticket before seeing this thread

Excuse my grammar.

I had to reinstall because of the same error. I thought it was my windows version and almost reinstalled windows. Dont do that.
After I made sure my drivers were up to date, I tried reinstalling getting stuck between 49% to 75% (I am reading that some got to 95%… U are my heroes for your patience!)

I cancelled it after 1 hour and restarted windows, making my installer, getting stuck just at the very start of “trying to update”, when opening it again.

I was about to file a looooong ticket about what did I do and found this topic, and after reading it all, decided to do the next (read all before acting)

  1. Searched for EVERY FOLDER called in the computer and deleted them (there were 3). Didnt touch any game file (I wouldnt dare!)
  2. Restarted windows.
  3. Tried running the Installer again, got the error of getting stuck in the install @49%
  4. Closed the installer.
  5. Getting the stuck now in “Updating” when opening the setup.
  6. Went to Program files x86 and found the folder called that someone mentioned, renamed it to ( Creativeness! )
  7. Opened the setup again, instead of getting stuck @ updating, it opened, allowing me to Log in.

This was a mixture of solutions of what I read here, nothing original. And a new folder appeared again after opening. But I wont close again my Bnet app until this is solved.

However, as I did delete all the folders before, the system said I had to tell it where my games were, having to update one or two.

Hope this finds you well and allows you to play

i have been able to solve my issue

i noticed if i tried to open hearthstone, a popup asked me to install bnet
trying through that worked in installing
and no longer have problem

I have the same issue and I’m too afraid to uninstall and reinstall to either have the same issue or entirely new issuess ;;

Has there been any new updates on this problem?

this worked for me .thanks cause I dont have the internet to redownload everything

go to program files> and find the folder. drag it to desktop . then open it. worked for me. comment was above


If you’re like me and renaming/removing from the folder get you to “blizzard agent went to sleep attempting to wake it up”, go to ProgramData/ and rename/remove Agent.8012 and you’ll get access to your games (it will download again Agent.8012 & however…).

Edit: Yeah ok… you’ll have to do the above steps everytimes you launch… Blizzard fix your sh*t please.