Bnet error when trying to open

Hi when I tried to open my bnet today I started getting the following error -

Battle.net\Battle.net\Battle.net.13747\libcef.dll is either not designed to run on windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0xc000007b.

I’ve never had any problems with bnet before and it was working fine just yesterday but today I’m getting that error I’m assuming there was a bnet update and it broke my bnet somehow, any ideas?

3 Likes

I’m having the same thing right now

Nice to know that it’s not just a problem on my end. I’m guessing there must have just been a bnet update at some point after I opened my bnet yesterday which just broke my bnet since nothing else changed. I guess it must only be impacting some users or we’d be seeing more posts about it, who knows.

1 Like

Same issue. Whats the workaround?

1 Like

I have the same problem. Windows 11 (insider build), fully updated.

2 Likes

Fixed by uninstalling Battle.net, then going to C:/ProgramData and deleting battle.net folder. Then reinstall.

To find ProgramData you have to toggle it visible (look up a guide if you cant find yours)

6 Likes

Hopefully we can get an official update on this, would like to avoid having to uninstall and delete folders if it can just be fixed by Blizzard since the problem isn’t on our end.

2 Likes

Hi,

Not sure what Blizzard can do… the Battle.Net App is on your PC and it’s broken.

==================================================================================

The steps suggested by @Csmug above are the exact same steps that you find here:

(blue-coloured words are links to additional information / steps.)

Note: The above steps may cause the Blizzard Battle.net desktop app to forget game install locations. If your games can’t be found, you will see Install on the Blizzard Battle.net desktop app game tab instead of Play. To find your installation, click Locate this game or run the game launcher.

Yes it’s on my PC and it’s broken, but it was only broken after the most recent update put out by Blizzard and it’s also broken for a bunch of different people all on different operating systems. It’s more so we shouldn’t have to troubleshoot a bunch of fixes for something they broke in the first place. Uninstalling and reinstalling isn’t guaranteed to fix whatever it is they did to cause it to stop working for us in the first place but if we have to we have to an official response would be nice though.

1 Like

I’m having the same issue. I uninstalled the BNet app and deleted the folder in ProgramData, and am now reinstalling the app. However, it’s taking far, far, FAR longer than it ever has, before–in fact, it’s stuck at 57%. I’m wondering if there isn’t some sort of larger issue going on. Anyone seen any official Blizzard statements on this?

Let us know how it goes, it worked for Csmug but I know of someone else also having the problem that it didn’t work for I also found some threads where people were having similar problems going back to the beginning of 2022 people deduced then too that it was right after an update so not sure what’s going on, just wanna play. :stuck_out_tongue:

1 Like

im having problems downloading games, stuck at 99%. have 500/500 fiber and switched regions to see if it helps but i dont… :frowning:

2 Likes

I can still log into my games manually, just by going to their folders on my computer and launching them that way, and then putting in my acc/pw in-game. But the launcher’s just completely busted.

That’s interesting, that doesn’t work for me since I think it tries to load the bnet client first so it just comes up with the same message.

If the normal uninstall/reinstall processes linked above do not work, then you can try doing a manual clear of the data. This addresses situations where data was corrupted and not properly removed by the uninstaller.

  1. Open file explorer/file manager (Right Click Windows Start)
  2. Navigate to the folder where the desktop application would normally be installed. Delete that folder if it exists (usually program files x86)
  3. Type the following into the address bar (not the search bar): %APPDATA% and press enter.
  4. Delete the Bnet and blizzard folders inside the appdata folder if they exist.
  5. Repeat steps 3 and 4 with %PROGRAMDATA% %LOCALAPPDATA% and %TEMP%
  6. Empty the recycle bin.
  7. Now reinstall the app to the C: Drive.
4 Likes

Actually just tried something random and it just so happened to work for me, since we had established that it was broken after the most recent update I went into my battle.net folder and I just moved out the most recent update folder which was “Battle.net.13747” since it was also a part of the error message and now it loaded just fine.

7 Likes

^ This worked for me.

Quick follow up update, after moving out the broken update folder (Battle.net.13747) and loading up bnet which it then worked fine I saw that the update folder got remade since the client would have auto updated after logging in I then exited out of my battlenet and back in to see if it would break again and yeah it did so I proceeded to just move out the newly remade 13747 folder and it works again when it only has the previous update to read from on launch so it’s something to do with the 13747 update for the people who are also experiencing the issue I guess.

1 Like

There definitely could be an issue with data in the recent version. If it keeps populating back when you clear it causing the issue to return, I recommend posting that in the bug report forums so the QA teams and devs can investigate it further.

Ah I see someone posted having the same issue on a topic in that subforum today too but the initial thread was from back in March. I’ll submit a post in there too hopefully it can get worked out thankfully for now I think just moving out the 13747 folder every time I load the client should work at least it’s working for now. Strange how it only seems to be affecting certain users though some on windows 11 myself on windows 10 and maybe some are on some other operating systems. Hopefully just moving out the folder works for other people experiencing the problem too since the person who posted on the topic in the bug report section is experiencing what I assumed would happen that he reinstalled it, it worked until it needed to be updated then he would just get the error again.