BLZBNTBGS80000023 Log in session has expired?!

Everyday I find that I have been automatically signed out of Battlenet, even though I have the “Keep me logged in” setting selected. There was a post in May about this issue but it has been closed and a fix or resolution was never provided. Are people still experiencing this issue that I am? It’s annoying to have to provide password everday even though I have 2FA enabled.

7 Likes

Both I and my wife have been having the problem for about a month now. You aren’t alone in this.

1 Like

I have the same issue and I have no idea how to fix it.

1 Like

happens every time my computer goes to sleep. when I comes back on, the app is signed out with an error message. then there is a “Retry” button that does nothing it just makes you sign in again.

1 Like

Hey everyone,

Thank you for reporting this! I didn’t find any known issues matching this error or description, but this behavior with the app could be caused by a file cache issue. Please try the steps below to fully remove Battle.net-related files on your system, and then reinstall it fresh:

  1. Uninstall the Blizzard Battle.net App (skip Step 6 for now, we will re-install later).

  2. Next (before re-installing) let’s delete any Battle.net, Blizzard, and/or Blizzard Entertainment folders in the Windows temporary file locations below. If you don’t see all 3 folders in each location, that is okay—just delete the folders you have):

    • Press Windows Key + R and type: %LOCALAPPDATA%. Delete any Battle.net, Blizzard, and/or Blizzard Entertainment folders.
    • Repeat the process for %APPDATA%, %TEMP%, and %PROGRAMDATA%. Delete any Battle.net, Blizzard, and/or Blizzard Entertainment folders.
  3. Finally, re-install the App.

Please let us know if that fixes the issue!

Well, I went through all of that and when attempting to redownload the desktop app via your Step 3 link the page for the download times out. Tried on three browsers, no VPNs or firewalls to muck up the connection. Any ideas?

Edited to update: a manual launch of World of Warcraft has initiated an installation of the Bnet app on it’s own, so I’ll update at a later point if the original session error persists.

So I am constantly having to log into the desktop app:

I read an article and it says my log in has expired but it does this everytime I open the app.

I have followed the advice in the article but it’s still happening. Is this a deliberate thing? Does the “remember me” function only last 24 hours? Prior to a few weeks ago I have never had to log in more than once a year…

I’m also experiencing this constant “login session expired” problem that seemed to be happening in that May thread Recoil references. I’m on a Mac, not a PC, but I did a complete delete and reinstall of the battle.net desktop app last night (as per https://us.battle.net/support/en/article/30304) and it has not resolved the issue at all, so something deeper appears to be amiss.

It’s been going on since Sept 12 (according to when I first complained about it in guild Discord :rofl:) and happens whenever I let my computer go to sleep or restart. I do use a laptop, so it connects to a few different networks, but that has always been the case as well, not a recent change.

I tried these steps and for me, it made it worse. Even closing my computer for 30 minutes causes this message

Is happening to me as well. If I click on the reconnect to online button it still tells me its unable to connect, which forces me to restart again. Fix the issue please. At the same time, inform your hearthstone support team that the same issue has plagued that game for nearly 3 years. I’ll play one round of battlegrounds, after the game is over, it’ll put me back at the start screen and ask me to reconnect as I’ve disconnected from the internet. But I’ll still be connected to the internet and other online games…

Same issue, whenever my PC goes to sleep the desktop client logs out

Same issue. I deleted battlenet, cache, reinstalled battlenet, installed beta battlenet, nothing works.

2 Likes

Im having the same issue too. I have the app on my work Mac and every time the computer goes to sleep I am logged out as well. Its an issue on both Windows and Mac apparently, and extremely frustrating.

Thanks Skelgarer, this worked for me. I only had the Blizzard Entertainment folder to delete after uninstalling. I was having to re-enter my password every single time the PC resumed from sleep but so far, the last thrree wake ups have been trouble free. Fingers crossed it stays that way :slight_smile:

i also had this problem the OP mentioned, however i had while using the beta variant of the desktop client. not the standard.

unknown to me if OP uses beta or standard.

followed steps you mentioned and reinstalled so will see if it causes prompt for re logging in after pc is sleep.

As a follow up to my post twelve days ago, I’m still having to relog and reauthenticate despite having “Keep me logged in” checked. Seems only to require it after shutdowns/reboots of my system. Closing the Bnet app and relaunching it doesn’t do it, however.

1 Like

Can confirm, having this issue as well. Fresh install of everything, so it is something wrong with the battle.net launcher.

Not really complaining though as this might just be the thing I need to get me to take a break from gaming. Going broke buying all the skins lol

3 Likes

I have discovered a bug in the Blizzard desktop application concerning user credentials being cleared while software is set for “remembering” user information. This condition creates a false check and a loop where the software will (upon users clicking Retry) try to log in with blank credentials. And the Error Code that is returned to the user is irrelevant to the condition. The error code suggests the user cannot log in due to the user’s network connectivity issues, but the real condition is the software is no longer asking the user for their email and password information after the session has expired. So the application tries to log in with blank data. This is obviously more likely to occur immediately after an authentication session expires.

I recommend creating a quick manner for the user to clear all saved settings for the desktop application (default settings), thus forcing the application to prompt the user for their email and password, and NOT try to automatically log in with null data fields.

Blizzard already suggests that people should uninstall and reinstall the application to get rid of “rare” application issues; but this bug is ridiculous and quite easily solvable with a slight code modification.

3 Likes

Same here. I experience this issue no matter what pc I use.

1 Like

My wife and I are experiencing this bug as well. Really really annoying

1 Like