Update Agent stuck

Trying to reinstall the app, have been scouring the internet looking for a fix, can’t find a single thing.

WoW server were incompatible, searched for a fix for that, ultimately ended up deciding to reinstall the app and game. Uninstalled/Deleted(as one of the solutions suggested) all Blizzard and Battlenet folders from my PC, trying to reinstall the app. It gets stuck at 45% “Updating Update Agent”

Ports are all open
Antivirus and Firewalls are completely disabled while trying
Even tried with my VPNs incase i was region locked for some reason
Internet is working fine, accept speed tests at normal levels, and i can download games from Steam.

Sooo… im out of solutions here. I need help.


I have the exact same issue. :confused:


Same issue here. Updating Update Agent… (45%)

1 Like

Same issue:
Tried all the the recommendations here - [ Update Agent stuck - Desktop App Tech Support - Blizzard Forums] battlenet-update-agent-stuck/46646 :

  1. Update your drivers to resolve any compatibility issues.
  2. Run a security scan to remove any viruses or malware infections.
  3. Configure your security software’s exception list to allow Blizzard applications to run.
  4. Create a new administrator account to resolve permissions issues.
  5. Uninstalling and reinstalling the App may resolve rare launcher issues.

I managed to get BNet installed again, after deleting all files app files / tempt files / etc through run commands and deleting the blizzard and bnet folders:

Then have issues with the updater again; stuck continuously on ‘waiting’ when trying to update WoW classic (Hardcore Hype). Finally have a Bnet crash which asks me to restart Bnet / PC. I do so, and then I receive the error again from the updater “BLZBNTBNA00000005” update agent went to sleep trying to wake it up.

All issues seem to stem from the interaction between Bnet and the Bnet updater. Uninstall Bnet after having deleted all files and I manage to get past the 45%, but I still have the issues with the Bnet update agent being asleep.

This is an endless cycle which always leads me back to not actually being able to update / play WoW.


I also have the same issue on a new PC.

1 Like

So here’s my story :

Everything works fine on WOTLK Classic until yesterday at 12’ when I tried to use my Hearhstone ingame and got the error message “Cancelled Transfert : Can’t find the instance” something like that. I started to have this error message very often at each area border or when I wanted to enter a dungeon. I got a loading screen with no progression and a rollback each time.

Decided to completely deleted and uninstall Battle.Net and all my files / games / etc

Now I can’t even install BattleNet, got the same issue with BattleNet Agent Stuck at 45%

What’s going on ? Is it due to the new Hardcore servers and all the people trying to login ?

1 Like

Very similar to your issue, even when I achieved to get BNet installed, got “Waiting for another update” all the time and it never manages to really install or update Wow Classic.


Still stuck at 45% after waiting for a whole night. Uninstall did not help.

1 Like

I have the same issue.
Got a new PC, tried to install Bnet, and stuck at 45% when install ing. Tried all other methods listed in other threads but not solve the issue.

1 Like

I had the same stuck at 45% issue since yesterday but got it fixed somehow. Not sure if it’s because of the changes I made or they just simply fixed the bug today…

What I did:

  1. Win+R → %ProgramData% → → Agent
    (Basically go to C:\ProgramData\\Agent)
  2. Under Agent folder, open ‘product’ file with Notepad
  3. Replace ‘.cn’ with ‘.enUS’ (or you can try just ‘.en’)

In my case I selected ‘Simplified Chinese’ for installation so I suspect it was trying to connect to the Chinese server.

Hope it works.


it actually worked for me. 好用爱了

Hey I do not see a product file. Any thoughts?

Same problem, going to re-download back to the client but it keeps getting stuck at 45%.

1 Like

What is going on? authenticator stops sincronyzing and after recover antrance to my account my two games dissapeard. Its been 3 weeks since i contact support and the just are playing games on me, no solutions whatsoever. WEe all deserve a fast solutions in this matter.

Bump, same problem, stuck at 45%

I guessed the reason but couldn’t find a way to reselect the language. Now it’s solved, thank you!

How did you do that?

Any Blizz to help?!? Can some Blizz explain if it is a sever problem och File problem?

I can see an error in the Agent:
[E 2023-08-28 19:19:16.0300] Failed to download url “h t t p ://”

Thanks for any help!

How did you do it please?

Thank you Oleoleo! 感谢老铁!

Same ordeal here and it was solved this way. I assume this happens to users that are located in US but chose a different language when installing This is the solution, tried and true.

Admin please pin this post so others can see. Thank you!