Battlenet Launcher in constant UPDATE/SCANNING Mode

After my character fell through the world and caused d/c’s upon re-peated logins, I followed the Blizz posts that said to Scan & Repair under Options. This caused an endless loop to UPDATE/SCANNING. The launcher blocks attempts to un-install and re-install the game with a “Woops, something went wrong” message. Followed another post saying “Delete *.IDX files under “Data” folder then re-run SCAN & REPAIR.” This did not correct the problem and the endless “UPDATE/SCANNING” problem resumes. This problem seems directly related to the Launcher but deleting the Battlenet launcher and re-installing it does not correct the issue either. COMPLETELY locked out of WoW…launcher seems to be blocking a login into “WoW Classic” which I don’t play to much but have…with the same UPDATE/SCANNING loop…though I did not initiate a Scan & Repair on that app. The Launcher is blocking any play whatsoever. I’ve also tried the Blizz post that says to create a new Windows Admin Account and try the Scan & Repair again. That also did NOT fix the problem-same result.

Blizz-please just tell me that you’ll have this fixed on Tuesday maintenance-that’s all I want to know. Long-term player…would like to stay with WoW.

12 Likes

Hey there Magusminor!

We appreciate you taking the time to report this. The most common cause of the Battle.net Desktop App getting stuck in this state is a conflicting third-party program such as an anti-virus. Be sure to fully update or temporarily uninstall security programs which may be preventing the Update Agent from running. More information on troubleshooting security applications here, if curious.

If this doesn’t apply nor fix the issue, can you temporarily test an alternate network such as a mobile hotspot or VPN? This will help us quickly determine whether the issues are network-related.

A similar problem is happening for me, I’ve been unable to play overwatch and warzone for months despite trying all the fixes available to me.

Here’s what I can tell you. I have no other virus protection other than Windows Security. I already used your suggestion of creating a new Windows Admin account per the instructions. This as a default has no Windows Security options enabled. The intent of this admin account was to figure out whether virus protection was blocking the updates. Again, this admin account did not correct the UPDATE/SCANNING loop.
As far as network connectivity: I have Comcast. There have been no service interruptions nor changes in ISP in recent history. I have Windows 10 (Home). There have been no Windows updates that I know of to account for this problem.
My system is fairly new. I play WoW everyday up until the new Launcher was rolled out. The launcher will not let me uninstall or reinstall WoW. I am able to uninstall and reinstall the Battlenet launcher but this does not correct the problem. I am at my witt’s end with this problem, guys.

7 Likes

Can you add a DxDiag here? I have another idea.

Click here to show/hide DxDiag instructions
  1. Press Windows Key + R, then type DxDiag and press Enter.
  2. In the DxDiag window, click Save All Information.
  3. Name the file “dxdiag” and click Save.

To add it to your reply here:

  1. Open the text file and copy all of the text.
  2. Paste the text in your reply.
  3. Highlight the pasted text and click </> on the post editor.

If your DxDiag does not fit in one message DO NOT shorten it. Instead, post it on Pastebin.com and provide the link to it, or the hash code (the numbers/letters after the .com) in your reply.

I’ve been trying to update and scan and repair my COD CW game. I’ve done it probably 20 times now, lol. The problem hasn’t been fixed. It happens all the time when Blizzard has an update. Ay ya yay, this is not good guys and gals !!! I don’t know what else to say

4 Likes

opened a ticket earlier for the exact same problem, have tried all the suggestions online, idx files, reinstall bnet, check security issues admin. In regards to Nicole’s comment I will post my DxDiag here as well just in case. Further more I have switched over to another internet provider that I have to see if that would fix the issue, it did not

here is my DxDiag if this helps at all

1 Like

not the problem, we are all starting to have the exact same issues YOU have to figure out on your end what is going on. I have tried to scan and repair 5 times, Uninstall and reinstall 2. its not working i have run scans on my virus protection, i have disabled it, I have checked any and all updates on my pc. its a blizzard issue
I get to the loading screen every time, and it then sits there and dc’s its not what you say because im almost in and as usual it dc’s pls fix the issue.
My issue started late last night, and then today I thought it would be ok, only to see its not.

4 Likes

LMFAO I found out the issue If any of you have the Blizzard Improved UI, DELETE IT!!! I placed that on last night and thats when I could not relog back in. I just deleted it and im fine. DELETE BLIAARD ADD ONS!

2 Likes

Where would I find the “Blizzard Improved UI?” Just want to see if I unknowingly have it installed. I have been on the same Scan and Repair loop as others and nothing seems to resolve it.

1 Like

Go to the add on site Curseforge that is run through Overwolf
Also if you are able to get to the Log in screen on the bottom left corner theres a tab for addons as well

2 Likes

Thanks. Not familiar with any of these services or sites but I will try to figure it out. Just downloaded Curseforge for Windows and will see what happens.

1 Like

https://pastebin.com/6yGVA8JX

Addons are User interface modifications for WoW made by other players. They are NOT supported or made by Blizzard. All they do is change the data display, including giving you more info about things - all based on the available back end data Blizzard provides.

You would have to go to an Addon site and intentionally download and unzip it. They are not executeable programs - but they can cause loading problems for WoW if they are not working right.

The basic troubleshooting is to preform a UI reset which involves the Cache, WTF, and Interface folders.
Detailed instructions here

And if it does not help, you can simply put the old folders back in (with the base name) and get your settings back.

im having the same issue except i cant even get the app to launch to begin with it i completely wipe my computer of all blizzard and battle net software disable my security then download the setup launcher for the 20th + time just to have it say an error on the blizzard side has occured and they will fix it soon (this started 4 days ago so soon seems to be out of the picture) my error code is

BLZBNTAGT000008FC

so please get to this issue soon it seems many players are also having trouble

2 Likes

My wife is having the exact same problem as everyone above. We have tried all the steps listed above and nothing seems to have helped. She is still caught in the update / scanning loop following the update today. Another odd thing is that when she goes into programs from the control panel, it lists WoW Classic, but not retail, almost as if the game isn’t even registering as there.

Bumping this so that tech support is aware that people are still having problems.

2 Likes

After deleting addons then trying the suggestion of renaming the folders (e.g. Interface -> “InterfaceOld”), the Blizzard Launcher Scanning/Update loop persisted. This time I uninstalled the Launcher then manually deleted the entire World of Warcraft directory on the c:\ drive. Not ideal but since the Windows Add/Remove function (i.e. “Remove”) was blocked by some lingering Launcher software), a hard/manual delete was the only option. I did backup my addons previously. I went to my Blizzard account and performed (still downloading now) a re-install of WoW. This install seems to be occurring successfully. The game is now playable and I am logged in. The nightmare of resetting my Bartender addon settings begins (backup of this addon seems imperfect for some reason, never have figured out why the exact configuration doesn’t get backed up on a backup…grrrr). If you download a “fresh” version of WoW from your account, you get the old/previous version of the Launcher. I see the option on the (previous) launcher to download the latest (From Friday?) Blizz Launcher update and am VERY afraid. I will try to avoid that as long as possible. Wish me luck. BTW-my conclusion was that “addons” had nothing to do with this problem, and due to all the troubleshooting as an end-user, given all the circumstances, sequence of events, and the ultimate fix was that the Blizzard Launcher rolled out on Friday was the root cause.

2 Likes

Also remember that if your char is stuck, there is an unstuck support option to move your char. Sometimes it is not just the addons, but the location.

If the UI reset does not help, try the char move option.

I never downloaded any add-ons and I have never downloaded or played WoW. So the problem is definitely caused by something else. This problem has been ongoing for nearly a week with no resolution. Still in the same Update/Scan and Repair loop. I have tried anything and everything I can think of, including the posted suggestions. To no avail.

I’m bumping this again, because I have been having the same issue for the past two days with Battle.net and WoW. I even uninstalled and reinstalled WoW yesterday, which fixed it for about 12 hours until I went into another loading screen.
Put a ticket in this evening, so I’ll try to keep y’all updated!