is locking up my entire computer keeps locking my computer, requiring a hard-boot to regain responsiveness. It’s happening after login, while it’s trying to find my Blizzard games.

Then attempting to uninstall it results in an error screen.

Same thing is happening to me now.

Also having this problem since this morning. For me it seems to trigger as the ads/panels in the center begin to animate in. Entire PC freezes and BSODs

I grabbed a new setup and installed a fresh one, but issue is still occurring.

This appears to be a common issue starting today, as I’ve seen the same threads on reddit and WoW forums. Same is happening to me.

On reddit, we found a common thread may be GeForce RTX,GTX GPUs, perhaps in the 20x series. Hopefully it gets fixed soon, but you can still play the games by launching them directly from the client folder.

I find I only have this issue when I am on the WoW page. None of the other games cause this. I’m assuming it is tied to their new movie. If you use for group talk, just keep it selected on any other game than WoW and launch WoW directly from the client folder.

1 Like

I have a Radeon 5700 XT and it definitely is the movie. When it first pops on the WoW video preview pane, it causes my screen to go black for a full second and then my app is wiped completely white in render. When I updated all my drivers, I see the video in question as a scrambled video preview. If I play it from the app, it appears to be the latest AWC championship video.

I was having this same issue and have found a temporary fix. My computer started crashing when the client would load. I found that if you disable the “Browser Hardware Acceleration” option in the settings (before you login, the gear in the top right, then go to advanced), it will stop crashing.

Not sure when this was added since the patch notes don’t seem to reference it and this only started happening today, but for now, just disable this setting and you should be able to run without a crash.

1 Like

This worked for me as well, thanks!

doing a DDU and reinstalling drivers worked for me

Having the same issue at the moment. Was perfectly fine all day yesterday.

Uninstall all drivers, restart your PC, reinstall drivers. Works perfectly now. double check you cleared cache before doing that too

I had the same problem, your temporary fix worked for me as well. I’ll check drivers, etc. after Tuesday’s patch. I didn’t start with the problem until yesterday either. Thanks!

1 Like

Hi everyone,

I’ve faced similar issues with causing my computer to freeze, much like the way some users experience crashes with the “Enhance Castle APK”—both seem to strain the system resources excessively.