Battle.net Desktop App Stuck at Scanning Game Files

Since the last patch, the game is not launching. As soon as I open the Battle.net App, it starts scanning the game files. I did delete the .IDX files and let it complete the scan/update, but no use, it is stuck. I appreciate your help.

11 Likes

dealing with the same thing on my end. No result. About to uninstall and reinstall the battle net app.

same with me, did just reinstall blizz app.
can’t start D3, need to be patched, but fails at the end, with “oops something broke”!

3 Likes

Cod CW
Same problem had a crash, something broken message.
Scanning loops. Tried the delete idx files but it gets to 100%, says updating briefly then back to scanning from 0% again.
Any solutions?

1 Like

Same here, scan and repair endless loop

1 Like

the same problem, reaches a certain point and sends me an error that something broke.

I seem to be having the same problem hopefully blizzard can get back to us sometime this year.

Same Problem here - It keeps looping on Scanning - it gets to 99% and then prompts for launch Blizzard in Admin mode - accepting yes restart the scanning and continues to the same and same and same.,

Did you launch it in administrator mode instead?

Yes I did launch in Admin Mode – still no luck.

Same problem for me since the uptade of 04/22
Scanning… restart… scanning… restart…

Have you tried changing your DNS? maybe it’s connection related?

The problem follows me, I can’t get out of that scan loop

1 Like

i have the same problem

Some users fixed by changing DNS or using a VPN (both of these are an ISP-related issue), or by turning off hardware acceleration in settings.

how can i change the dns ?

i alredy turn off the hardware acceleration also change dns and still not working what else i have to do this is frustrating ?

I’m a volunteer just offering suggestions. I’m not experiencing this issue, so I don’t have any other insight.

Hi @Nicole,

I do appreciate you helping.
I have tried all but to no avail.

I have even change the battlenet exe to run as administrator, now the behavior is "scanning 0… 100% " than “initializing 0%…” back to “scanning…”

Any other ideas?

The most common reasons for this happening are related to hard drive space availability, security programs, work software (like Citrix), ISP throttling, or DNS issues. That’s all I know of besides the administrator mode trick.