Battle.net app started when I turned computer on, but I have that option turned off?

Hello!

I’m just a little spooked. I recently got back into WoW (2 days ago) and just this morning, when I turned on my desktop computer, the battle.net launcher started and was on the WoW page, but without me prompting the computer to open it.

I have it set to require my input to open and not to launch of Windows 10 startup.

Malware scan points to no malware… is this a bug of some kind?

3 Likes

Experiencing the exact same behaviour. Hope it is just a bug. I uninstalled it for now as I only play Hearthstone and can do so via mobile.

I’m seeing a similar issue. I do have it configured to launch at login, but I have it configured to launch minimized. As of this update (1.19.0.11806) it’s launching with the window presented.

Did this last update break how it reads launch settings?

Similar issue here. Every time Windows 10 boots up to desktop, Battlenet launcher always opens up to the main screen even though it is set to minimize to system tray. Very very irritating.

Same here, except I don’t have the “launch Bnet when you start your computer” box checked at all.
Also Bnet is not on my list of startup programs in Task Maganer. Very weird, and dosconcerting. Plz fix @Blizzard.

Same here. App starts and is running when I boot my Comp. Checked all settings. Its defiantly set to not do this. Box is unchecked in setting and app is not even listed in my startup menus. I must say, Its sort of disturbing that this app can circumnavigate my computers settings and do whatever it likes. Can we get a blue response on this please?

This is happening with my app as well. This option is turned off in my settings and not set in my Task Manager to boot at the Windows startup. A bit disturbing to be honest.

Must be a bug in the recent update. Windows 10 is treating it the same as Chrome, so if you shut down or restart with the app still running, it “resumes” by opening it again.

If you want to avoid this, you need to exit completely (right click taskbar icon and pick “exit”) before shutting down.

I haven’t tested yet, but you might also be able to ENABLE startup launching, start task manager, go to “startup”, and then disable it there, but I think that might not be ideal (I’m not saying it can or will, but i can imagine it’s not great for the software).

Same here, i even turned on and off the startup option and restarted every time. Hopefully they fix this.

Hi Sleepless…

Will test your idea out. I’ve had chrome start for me automatically sometimes when I forget to turn it off before shutting down the computer.

Maybe it’s the same thing.

Thank you for raising this issue to us. It is indeed a bug and we are currently looking into it.

1 Like

Thank you! It is appreciated.

I’ve tested it a few times myself already, mostly because i’m paranoid. It worked for me.

Just chiming in to say that I am experiencing this issue on multiple different Windows 10 computers as well.

Thank you for the confirmation. Cheers! <3

We’ve just released an update to the Battle.net app that should resolve this issue.

Please let us know if you are continuing to experience anything similar.

The app still stays open in task manager after exiting.

I’m still having this issue as well, using MacOS. In my case, it used to open even though open at Login was disabled. Today the open at Login re-enabled itself, and now I can’t uncheck it anymore.

EDIT:

I fixed it myself, it turns out in the OS system preferences, there’s login options and if it’s enabled through that method, just right clicking in the dock won’t work. You have to go back to the system preferences to disable it.

I’m on mac as well, it’s not a log in item on the system preferences, and it’s not checked in the battle.net menu either, but it keeps loading up every single time I reset my computer.

It’s super annoying.

Hey, squidrabble! Could you try uninstalling the Blizzard Application? Do not skip clearing the cache/tools folders or the preferences files steps, then reinstall.

Sometimes, with Macs when the Blizzard Application is docked, it won’t update properly, a clean reinstall should take care of this. Let’s check the version to ensure its up to date. Go to Blizzard > Settings in the App, then check the bottom left corner. You should see Version 1.20.3.11914.