Battle.net Agent bug keeping Mac users out of game

Currently 1.6K views - listed in the Mac technical support forums for World of Warcraft but it’s clearly a Battle.net app issue.

Had this been discussed here? I can’t seem to find it - but is anyone aware as to what is going on?
No work around or fix?

Mac users and even some PC users can’t update World of Warcraft patch content to even get to the PLAY option due to agent saying we are not admin.

4 Likes

100% still a thing, keeps asking for Agent permissions, then spins its wheels ‘initializing’ and eventually errors out Error code: BLZBNTAGT00000BB8. Except i don’t have any connection issues, firewalls, proxies or anything interferring. There’s a Blizzard error, that needs resolution, Stat.

3 Likes

I’ve tried the work around and re install and it worked once and now it’s back to giving me that same message.
Completely frustrating that you can’t talk to a single person about the issue and trying to report it leads you only to a forum where we are only talking amongst ourselves - what is the purpose if no one will acknowledge the issue isnt on our ends?
Paying monthly for a product you can’t even get technical support for is sad especially when the company is already in a poor public light. Customer service and the ability to know that it’s not just one person having an issue at this point should be on the front burner in these days of technology.
Not looking good.
This is the second time in a year I’ve been kept out of wow for more than several days at a time with no word from the company in which the issue resides.
We shouldn’t be left to hacking just to get this to work.

2 Likes

I just encountered this same problem on my laptop today…but my laptop was working fine before the bnet update. I get the update button… then the Agent wants to make changes box for me to put in my password. I enter my password. It says, “Initializing”. Then I get a pop up window “Whoops! Looks like something broke” Give it another shot.

Blizz, can you fix this? If this is going to go and go and go and not be fixed quick, it’s going to be a factor when I consider renewing my subscription, TBH.

Hello,
Exactly the same thing for me.
Blizzard, could you fix the issue ASAP?

Figured out a fix this AM for me at least…it requires reinstalling the games…

Close out of Battle.net App
Go to Finder → Mac HD → Users → Shared
Delete the battle.net folder
Open Battle.net App, a re-install all games.

Yeah, same here! I thought it was my Mac (it’s old but still works even if it’s falling apart) to play the trial for a bit, but now??? it’s doing the same thing on my PC and I AM the admin on BOTH.!

attempted that, but doesn’t work. Now it’s just in an endless loading loop with the battle net symbol.

I just a few hours ago purchased a 6 moon sub to try and get back into WoW and I am SO disappointed to have to be having this same exact issue. I’m adding a comment to this thread so I can hopefully be notified when this issue is rectified. Blizzard… we love this game, we pay our money and want to be apart of all of the hard work that you guys produce. I know that issues and bugs happen, but to see that people have been dealing with this for several days is unacceptable. PLEASE fix this issue, for 1, but also please add an option for us to speak with you all directly in a chat to be able to quickly get you alls attention to these issues so that you guys can be faster at rectifying them. I wanted to pull an all nighter with my friends.

I love this game, this is no shade at all, just please help us help you.

Also if we could get blood elf shamans, I will love you all forever.

I will install install W10 on my IMac, it will solve the issue.

if I ever have to follow the instructions to uninstall and reinstall the games I swear imma just be done with Blizzard. usually just opening and closing the launcher multiple times fixes updating issues for me

Did a update on my Imac and i need too login Agent ?, never done that before and came with same problem …Whoops! Looks like something broke.
try too reinstall but same problem, hope for a fix

Still zero fix as of yet.

i get back from the nightmare called New World, saying : ok new patch and anniversary, relog to WoW… and now… agent bug…

Same issue, the game asks for pending update - when I click to update it says its missing admin permission, only one user on this Mac - and it is Admin - all permissions granted to Blizz.
Running MacOS 12.0.1 on MacPro 13 2019.
The game have been down for days now - no solution in sight, terrible experience.