Battle net launcher extremely slow

Hello,

My launcher is extremely SLOW. It takes a 1-2 minutes to initialize/logging in and then another until it becomes responsive and being able to click any buttons. Anyone else having the same issue? Inetcpl.cpl checked. Reinstalling done. Win 10 x64. Any advice is appreciated.

5 Likes

Hey Siawase,

While you may have already tried reinstalling, make sure you’ve tried these steps specifically:

  1. Uninstall the Blizzard app

  2. Next open the temp locations and delete any Battlenet and Blizzard folders you see in each location. Press Windows Key + R and type:
    • %LOCALAPPDATA%
    • %APPDATA%
    • %TEMP%
    • %PROGRAMDATA%

  3. Finally go ahead and reinstall the app from here. Make sure you run as Admin.

You may also want to try disabling the hardware acceleration option by clicking the Blizzard logo > Settings > General > Advanced Settings > Use browser hardware acceleration when available.

1 Like

Have similar issue, but this did not help.

The app ran flawlessly, until one day, it just did not start. I restarted PC, I reinstalled the app, I did also erase everything as you stated, but nothing happens. I ran the app as an administrator, after cca 1 minute the app starts and I can log in. Or can I? After I hit the Log In button, for a second it seems like it is loading, then the app disappears and it never starts. Once it randomly started after tens of minutes.

Every other app runs perfectly correct in my PC. Steam, Epic, Discord, browser, other games, everything.

Thank you, in advance.

3 Likes

if you have cox cable the bandwith is being compressed by cox cable unless you get a certain router by them it happened to me too.

Howdy Dodolinous,

That sounds like there is another program causing a conflict. Typically this is security software that may be blocking the app from working correctly. If you have security software, try adding the Blizzard app as an exception.

this customer support guys are just making fun of us I am serious. C’mon havent you ever downloaded your own game ? it’s just toooooooo slow just accept that your blizzard installer is total mess. my internet speed is 200 mb/s and I just tested it. but when I download warzone blizzard speed is just 4 mb/s . honestly I dont think there is any worse servers than blizzard’s. keep it maybe make it worse. good job

7 Likes

We’ve been given a system that has no support yet, wonderful, as if their service prior was not already comical.

4 Likes

Same problem, slow to launch, slow to login, slow to display main window, slow to do anything. Takes me almost 5 minutes to start the launcher app, login, and launch a game. Been like this since summer 2021. Gave feedback via launcher about this, no one has contacted me or provided a fix. Uninstaller kept failing so I had to wipe all installation folders manually to remove, yet problem persisted after reinstalling. Added launcher app to my AV whitelist, still slow as f***. Win 7 x64

2 Likes

Still taking way too long to start the launcher. Why is this not being addressed?

2 Likes

I am unable to play WOTLK Classic at all. Was working fine until today. I have done everything suggested in this thread. I launch BN and hit play and I get the black screen that does nothing. I have left it running for over 10 minutes. Nothing. If I move my mouse or hit a button I get a app is not responding message. I can wait or close. Tried both options game never launches. Help.

You need to post your issue in the WOW Classic forum. This thread is for the Battle.net Launcher app, not a game.

It is a battle.net problem. I even tried launching retail and it does the exact same thing.

2 Likes

Well here we are midway in 2023 and I am glad I found THIS article that addresses the same exact problem I have been having for awhile now and it seems others have been having for years. Glad I am not the only one having this issue. Since none of the “fixes” seem to work that the Blizzard Customer Service has advised I guess I’ll go watch a movie while it loads up and come back later…

1 Like

This is happening to me again after uninstalling the Diablo IV server slam. The launcher starts up okay, but trying to play Diablo II Resurrected results in a “Failure to authenticate” when I try to get to online characters.

Fortunately ("-}), I know when things are in this broken state, because the two logo displays become extremely laggy and stuttering when things are in this state. Unfortunately, deleting the battle.net cache has not fixed this as it has in the past, and reinstalling the Battle.net app did not fix it either.

Yeah been having this issue for a while at least yall get logged in my app never logs in it will say connecting forever and i just completely reset my pc and had to download everything again so re downloading it doesn’t work🙄

same here feels like its onnecting threw eu or sumthing 800+ping launcher

1 Like

I finally came looking to see what this issue is about as it’s been happening to me since maybe spring of this year ('23). I’m not completely sure of the date as I’m normally watching or reading something else when I load a game (EDIT: yes, I used multiple tabs on two screens both before and after this began happening, and even initially thought that was the reason. I’ve tested this by having nothing else open and the result is the same) but it’s exactly as others have said: one day it was fine, then suddenly it takes up to ten minutes before the load screen even pops. This issue affects no other streaming or otherwise loading applications I use.

Well, looks like this is a common issue with the launcher D: Just got hit with this issue myself, and have no clue on how to sort it out. I’m wondering if it’s not tied to an update somewhere o.o like a client update or a windows update that goes screwy x.x

I haven’t seen a blue post on the slow update/download issue… and may have a fix for the others experiencing it… as well as something for Blizz to look into regarding the issue.

(See attached response i made on another post)

The may be a permanent solution if you don’t mind using the beta bnet launcher (I had for over 6 months without issue.)

I was running the beta version of bnet and never had this issue. I had recently uninstalled bnet on my pc and reinstalled and began encountering this issue. (No, there wasn’t a limit on the download speed. I tired with both the box unchecked, then set to 150,000 kb, same results, either way)

It took me a bit to remember I was running the beta version previously, and the new install was the base version.

After updating to the beta version (an option in the bnet settings), the problem disappeared.

Note: The download on the beta will also drop, briefly after the initial pulse… but unlike the live app, it WILL recover… eventually giving me 60+mb/s, “my” blizzard norm, both times i tried it by installing/deleting Wrath whose download was also broken on the base app. (This was after the beta app had already fixed the DF download issue).

I’m unsure what the specific differences are between the apps regarding the relevant code, but tech support needs to look into it and correct the issue with the current production app.

Edit: Like many others, I have more than sufficient bandwidth, sync 500mb plan on 1g fiber and were/am not having issues with downloads from anywhere else. 540mb down and 480mb up on speed tests… other downloads only limited by server side throttling… 50mb or 150mb in most cases. FTP downloads from my cousin, who is on a sync 250mb plan, come in at 250mb.

Obviously, some reports will involve client side pc/network issues. Please just be aware that not all of them being reported at the moment fall into that category.

Your clients just want a guaranteed download and play experience, for this, you might fall in the near future due to bigtime client loss. whats going on?, is Blizzard doing auto-sabotage?