“This game cannot be played yet” MW Beta

I have pre-purchased the Vault edition of the game. the status is complete. The MW2 Beta had been pre downloaded 3 times now and still the link says “this game cannot be played yet” even though it is available for other people.


I am also having this issue, I also preordered the vault edition through battle net, re-downloaded 6 times now, will launch using a friends account who can play but is greyed out when I log back into my account, so it looks like it’s an account lock.


got the same issue, i bought the beta code and still cant play.


I’ve purchased the vault edition too and here is what happening to me the game start in background on the task manager for a few seconds and nothing after that, I checked the windows update and the driver update and both are updated and I tried scan and repair also nothing I unstalled it and installed it again and nothing also

what should I doooo

still nothing 5 hours later

Same here, purchased as soon as it was available and spent $400 for the entire family and I’M THE ONE THAT CAN’T PLAY IT!!! After spending this much, I deserve to give you this “constructive criticism”: fix the issue sooner rather than later.

or at least a work around, something

Same issue here. I opened up a support ticket with Blizzard 4 hours ago with no response yet. I love feeling robbed by activision. Lost a day worth of content as well but I’m sure everyone will want to watch my content after everyone else already posted it. Thanks guys

Has anyone, anywhere been able to play today?

Are there any replies? or is it I can’t find them? lol!

1 Like

Nothing is changing ive been refreshing the page periodically

I haven’t heard anything, I loaded it up on my playstation but I didn’t preorder it there I preorder it on battle net for my PC. Of course there is a timed reward too. We have to lvl to 30 to get all rewards but can’t access. This is ridiculous

chris what the hell man

Bro same issue
I have redownloaded the game twice, updated my pc, updated my drivers, looked up “fixes” for hours manly to get nothing but how to pre-load the game. there is no support that lets you talk with someone who knows the system better to get some help from blizzard or activation. plus blizzard (battle.net owners) said they would add the beta key to our accounts automatically and i do not know who to go to for support because idek who the issue is with

Hello all. I’ve been having issues where I cannot click the play button. It says this game cannot be played. I read on reddit to change your battle.net password. It worked for me. I closed BattleNet app on my pc down. Then went online to change my password. Then logged back into the BattleNet app with the new password and it worked. Please share.


I can confirm this worked!!! update password on battle.net SEE ABOVE!!!

1 Like

Tried the update password thing and still not working for me :frowning:


thats the old bnet… nothing works unless people cry about it. Im not pre ordering anything untill everything is straight for users to play…

I’ve reset my passwords and checked for Battle.Net updates… everything is up to par and still cannot access the MW Multiplayer Beta… I do not know what else to do other than try to get a refund

I too have tried the suggested fixes and it still isn’t installing. What the heck. I paid for the access either provide a fix for the issue so I can have access or refund our money Blizzard/Activision.