Windows 10, VR, and WoW

I have a laptop with Windows 10, VR, and WoW. As of the last patch, I am not able to update my wow client, so I can not play.

I have done all of the troubleshooting steps, and I still can not update. WoW, and Blizzard are totally cool with all of their trouble shooting guides, but it is still not working.

I wonder with the uninstalling and reinstalling of the client and Anti Virus software could I have broke the registry or got a file locked that is preventing the launcher from doing the update.

I will tell you that you have a few issues, and here is how I solved it.

I actually bought a laptop just for my VR setup, and bought a desktop for my WoW setup. But I went ahead and got myself a USB Flash Drive, and I made a windows 10 boot usb, and put WoW on it as well, and when I reinstalled Windows 10, with all the drivers, and put back on it found my wow game, and did the update and I was up and playing WoW in about 30 minutes on retail. So try to reinstall your OS and and it should fix all your problems, at least it did for me.

You could also try and doing a factory reset on your internet system, and see if the router, or modem, had a hiccup as this was happening. Also have you tried updating via ethernet, if you are on WiFi.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.