Where the hell is dreamwalk?

I made the mistake of leveling my druid through Legion, and after completing the order hall quest I was supposed to get dreamwalk but didn’t. So I assumed that maybe I had to wait until I got Teleport Moonglade at level 22 (which is an unbelievably stupid decision in itself), but I still didn’t get it. I can’t see it anywhere in my spellbook, and I can’t seem to get it from talking to anybody.

How do you fix this? More importantly, how did this manage to slip through after the ptr was up for months?

There are a couple of threads on this in the Druid forums


In the mean time, are you able to get into the area from Val’sharah?

A) Those don’t have solutions, they’re merely complaints.

B) They, at the time of writing, didn’t get Teleport Moonglade. I have and the problem still persists.

feedback in the forum the Devs take feedback about druids in

I’ve never seen anything in the patch notes about Dreamwalk being removed, and it’s still present on a 50 Druid I have on the other faction so it’s clearly not intended to be missing. As such, this is almost certainly an issue with the character rather than with class tuning.

Please, read before responding.

If you want to give feedback on this issue, post in the Druid forum. One of the threads I listed would be a good choice.

If you think it’s a bug, file a bug report.

The Customer Support forum is a player-helping-player forum with Blizzard oversight. The Devs don’t take feedback or suggestions from here. QA does not take bug reports from here. The SFAs who post here are not liaisons with either group.

Edit:
Since you haven’t answered yet. Have you tried going into Dreamwalk from Val’sharah through the portal in the Druid Class Hall?

3 Likes

“Customer Support: Blizzard Support Agent moderated forum to discuss and inquire about in-game and account related issues”

This is clearly an in-game issue, considering what I’ve written about it above which you’ve clearly failed to read. This isn’t “feedback or suggestions”, it is a report that something went wrong with my character that can only be corrected by an agent.

The threads you keep alluding to are, as I mentioned earlier, not relevant to my issue nor they do they have any constructive information even if they were.

“Have you tried going into Dreamwalk from Val’sharah through the portal in the Druid Class Hall?”

That’s irrelevant, as it’s not entering the zone manually that’s the issue but the lack of the teleport ability that I am supposed to have.

It is feedback or a bug report. You are giving information about an issue in the game. There is nothing Customer Support can do to help you. Customer Support does not fix bugs. Customer Support does not take feedback. You trying to claim otherwise does not change it.

So start a new thread in the Druid forum with your specific situation.

I gave you a possible work-around. You chose to argue about my reading comprehension.

8 Likes

A few things: The blues here ain’t able to fix bugs, take bug reports or fix that game in general. More to the point, the is a player-to-player forum with blues as mods. They’re not going to fix or look into anything like this as their main job is to be the front desk to the forums.

No amount of posting will make this forum the bug report forum, nor force a fix.

6 Likes

Someone else has posted about this in Bug Reports with the same work-around that I mentioned.

5 Likes

SOLVED! There is a portal in moonglade which gets you there. (right down part)

3 Likes

There are a few in there, including mine which is quoted above. I don’t think we’re a priority right now.

It still happening does not indicate it’s a low priority. The issue may be that the fix is more complex than players think.

Edit:
Proof it was a priority.

3 Likes