Website is removing posts because "no active game time"

2 Likes

Me too…just finished posting on the forum about not being able to connect and this happened.

I am active but the forums think I am not. Right now Website Bug Report is the only place I can post.

I’m suddenly getting “You need a level 10 character to post the forums” message everywhere I login. And also the “You need an active World of Warcraft subscription to post on this forum” message.

This current browser session where I’m posting this - it’s in Chrome browser on an old laptop. It’s the only computer and browser that recognizes my character. Tried logging in on this computer in Firefox, and it’s completely broken - it prompts for username and password, I click Login, it shows the authenticator page for a couple of seconds and then immediately redirects back to login page. I keep clicking “Approve” on my phone authenticator but it doesn’t stay on the page long enough to recognize it.

I tried multiple browsers on my other computer and my phone (including clearing all cache and cookies, and using an incognito window). They let me login but insist that I don’t have any game time or a high-level character.

Changing your password can force a refresh of your character data. Log in, out, and back into the forum after the password change to refresh the website data.

If the issue is just “No Active Game Time”, just log in and out of the forum a couple of times to refresh the data. Generally no need for a password change in that situation.