Warmode Toggled on, Not actually ON

EXTREMELY IRRITATING to have to keep going back to a capital city after turning it on and going out to do Sparks world quests ONLY to see players flying by are orange and nto red-attackable.

FIX THIS NOW. I’ve found I’ve had to stay in a city as long as five minutes for it to actually stay toggle don before I go out.

It shows itself ON and active and green but it is not in fact so. I’ve wasted more than one WQ on this garbage.

2 Likes

What seems to be the problem again…? You turn on War Mode and leave Valdrakken, and you go about your day doing WPvP. If you see players that are orange or unattackable, they’re likely on a flight path or are doing a dragon riding race, in which case they will be unattackable during that.

This is a repeat problem in stormwind or Valdrakken

Turn on WM and leave city, and it’s green-lighted on corner of my map.

But then I find it’s not actually on , as in I receive no sparks of life, players on the GROUND are not attackable. They’re orange and not attackable. Very frustrating moment

I have to go back to city and flip it back on, BUT I have to stay in city for 5 minutes or more otherwise it will turn back off again and waste my WQ’s that end up giving me no sparks.

This problem also happens in the other direction:

I noticed this first when I would try to follow a friend to quest outside of a town, and my WM is still on and I’d auto dismount to my demise. Me going back to town, turning off WM, and leaving, didn’t work. WM would stay ON and I’d need to wait several minutes for it to actually stay and not keep resuming its former toggle.

2 Likes

I’m a bit confused here because I’ve never heard of this bug happening. Are you confusing War Mode with PvP toggle? Im assuming this because you’re saying wait 5 minutes which, coincidentally, is how long it takes for a PvP toggle to turn off once you disable it.

War Mode is turned on from the talent page. It’s completely different from enabling PvP (by right clicking your character icon and turning Player vs Player on). If War Mode is suddenly turning “off” it could be an addon that’s interacting with it weirdly. Try turning off all of your addons and see if you still have the issue. You can turn off War Mode in any rested area, but can only turn War Mode on in Org/Sw/Vald. I’ve never heard of War Mode suddenly turning off/on.

War mode , the green light toggle on your talent page, mb. I’ll try to tl;dr

2 problems:

1.] WM won’t turn on after toggling w/o staying in city for a few minutes. When I flip it on and leave, I find out too late after doing WQ that it’s not giving me sparks, and players are orange. I open talents, the green light is ON. When I get back to city and click on it expecting it to go blank into OFF, it actually flips ON again. So it is lying about actually being on.

2.] Trying to turn it off is same problem, have to stay inside of city a few minutes. When I try to leave i find my WM is on and a friend’s is off so I get dismounted off their mount.

So I go to city, turn it off, and head back out, but still cannot see them they are ‘phased’. Same issue: I run back to city and click on my War Mode icon on my talent page which HAS NO GREEN LIGHT INDICATING ON, but my WM is indeed, ON, even though the light is blank, because once I click it the text pops up my WM is disabled. Then I wait minutes, and i can leave and see my friend.

The toggle is not working unless I stay in city for several minutes, otherwise it reverts the setting AND fails to tell me the setting reverted.

I.E. , I see orange players, and get no sparks of life despite the green light being on. Because, it’s not technically ‘on’, and I need to go back to city to turn it on, and sit and stay there so it does not revert.

you need to just land in valdrakken and turn it on. I’ve had it happen where I fly through rq and turn it on and leave right away. Just land for 10 seconds, leave.

i’ve tried different times sometimes it’s at least 2 minutes.

Does it happen on other characters? Also, yeah, you have to wait for your character to shard into Valdrakken before turning on War Mode. If you turn it on while you’re sharding into the city, it’ll look like it worked, but won’t. Once you’re able to see other players and NPCs inside Valdrakken, it’s safe to turn on War Mode.

Actually yes now I recall, on both warrior and paladin.

Well you could always try resetting your UI and also checking if it’s an addon that’s interfering. I’d start with checking if addons first, if not then resetting your UI (deleting cache and WTF folders, etc.)