Vigilant Guardian unstable cores not clickable

Any word from blizzard on a fix? Its still happening.

Is it possible a player has somehow altered the files on the WoW server in an act of hostile subterfuge? i.e. Agent Smith in the Matrix? Asking for a friend.

same issue, last night in normal, and tonight in heroic, only 1 person can click

I’m pretty sure our dumb demon hunter broke the whole dungeon. He tried to grab the orb once and it was bugged af the rest of the night. Please ban his character kthnx

So March 17th…anyone know if this is fixed yet because it’s been crickets from Blizz

Looks like there’s a fix for this in the latest patch notes.

Thanks!

I guess it will be fixed on server reset because we still has issues with the orbs tonight on heroic.

Same issue for us last night. We continued to experience issues in being able to pick up the orbs, after the hot-fix. Had people spam clicking it, but they were only able to pick up the orb seconds before we wiped to the AOE.

This is still not fixed.

1 Like

My guild had same issue for normal, worked fine in heroic.
On normal we were able to pick up a couple of orbs after spam clicking, third one wasn’t working at all and wiped us.

I hope that this small indie company can find some funding to fix this bug.

Don’t think it’s bugged. Guild did heroic/normal just fine.

We just did normal VG and it still bugged. Not as bad as last week but orbs still took multiple clicks to pick them up.

The group I ran with last night wiped twice on normal because nobody was able to pick up any orbs despite multiple attempts. The third pull worked, however. We assigned one person to focus on it on the third attempt, so I’m not sure if more than one person tries to pick it up at once it bugs out? I can’t say for sure what caused it to work once after not working twice.

1 Like

Unable to click as of tonight, Heroic difficulty.

Mythic vigilant, cores cannot be clicked

Same for my group. Mythic Vigilant. Cores cannot be picked up.

Having same issue tonight in Heroic, cleared ok on Normal

Also same issue tonight on heroic.

Same issue on heroic mode in tonight’s raid…

I have seen this happen on N/H/M difficulties, personally trying to click, pulling the boss away to click, we tried a lot but it seemed random who could or could not click it