Under Suspicion Daily Secret - Multiple bugs

I went to get the secret quest for the day from the inn and the first issue seems to be it has skipped over A Curious Orb in the quest order.

Not noticing that initially I followed the quest anyway and when I turned it in to Fangli Hoot she gave me both the item to search a list of locations and a quest to immediately turn in as if I’d already solved it. Me being stupid I abandoned this quest and the item, Compiled Report, would not let me take the quest again as it stated I didn’t meet the requirements. Deleting the Compiled Report also does not allow me to get the quest again and neither does actually solving the clues so I’m completely unable to complete it now.


Can confirm happened / happening to me right now

I’m having the exact same issue.

Same Issue here too

confirmed same issue

My issue isn’t exactly the same, but it still broke. I didn’t abandon the second quest. I completed it without realizing what I was doing.

I now have “Under Suspicion” completed without having done anything. I can’t follow the clue anymore to still do it, and it seems to have skipped over “A Curious Orb” completely.


this is what happened to me as well just to confirm

That would have been the smart thing to do but I’m not smart. Definitely shouldn’t have been broken and handing out the final part with the first part to begin with though.


this TBH ^

If I was paying more attention I probably would have done what you did. Either way the whole thing is broken though, so hopefully any fix will help all of us.

1 Like

James and I were doing this event together, and we both had the same issue.

I just wanna ask and try and confirm something to for all our sakes… Since there is no info on it I can find at this current moment… AH one… that is technically the first one right? Its the first one me and my friend tried cause I assume you do the note in order like the others… The note in AH isnt like the second one or something right? I just wanna confirm what order we all tried them in to me and my friend went to AH one first cause her friends said that was first one

feel dumb for asking did we all do the note in order… Like good people we should haha but maybe we should try the others?

1 Like

The note does say the order you discover them in and, yeah, fountain → auction house is the first one.

1 Like

that makes me feel a little better then cause yeah i dont see why you would have to do the others first unless its “shadow random” for everyone and they just didnt tell anyone which i hiiiiighly doubt

This is what i think happened, when she gave us the initial clue, it should have only had the go to the fountain clue on it, but it instead had EVERY clue on it already, thus having it completed already.


I did them all anyway. The note started with “a note on the back shows you have successfully solved this clue” on it and that got bumped to the final page with each clue I solved. Seems it’s bugged and flagging it as completed even when it’s not. And the rest of the quest isn’t completable because of it.

I have been checking for wowhead info to cause once people tend to get it its not long till they release it there… theres stiiiiilll nothing about this so im fully on the train with you guys its broken and bugged needs fixing cause they might take a hot min to release the info… but it didnt take this long before to do it and people are still running up to mine on MG server and saying they cant do it

Happened to me too…completed but not the right one …

Yeah it’s weird they haven’t said anything. Maybe they’re waiting for confirmation of an issue to report on it.